Pear problem

pppplus

Verified User
Joined
Dec 19, 2008
Messages
524
[solved] Pear problem

Hi

I've a problem to upgrade Pear.
I need Pear to use mail fonctions.

After upgrading to PHP 5.6, a lot of packages disappear.

I want to reinstall them, but I've error messages like that :
Code:
pear/Net_Socket requires PEAR Installer (version >= 1.10.1), installed version is 1.9.4
I upgrade to Pear 1.10.3, but I've always the same error message (message above !)

Code:
# pear version
[COLOR="#FF0000"]PEAR Version: 1.9.4[/COLOR]
PHP Version: 5.6.30
Zend Engine Version: 2.6.0
Running on: Linux host1v101 2.6.32-40-pve #1 SMP Fri Jul 24 11:16:05 CEST 2015 x86_64
[root]# pear list
Installed packages, channel pear.php.net:
=========================================
Package            Version  State
Archive_Tar        1.4.2    stable
Console_Getopt     1.4.1    stable
Console_GetoptPlus 1.0.0RC1 beta
Mail               1.3.0    stable
Mail_Mime          1.10.0   stable
[COLOR="#FF0000"]PEAR               1.10.3   stable[/COLOR]
Structures_Graph   1.1.1    stable
XML_Util           1.3.0    stable
version returns 1.9.4
list returns 1.10.3


I probably forgot to do something, but I don't find what.
 
Last edited:

pppplus

Verified User
Joined
Dec 19, 2008
Messages
524
Solved !
I have several version of PHP.

I have to use the full path, so /usr/local/php56/bin/pear
 
Top