PHP 5.3 PCRE problem

jstsch

Verified User
Joined
Dec 10, 2010
Messages
5
Running a stock Centos 5 machine with DirectAdmin. Set PHP version to 5.3 (./build set php5_ver 5.3), but got a problem with PCRE:

Code:
Warning: preg_match_all() [function.preg-match-all]: Internal pcre_fullinfo() error -3 in /var/www/html/phpMyAdmin-3.3.8.1-all-languages/libraries/Message.class.php on line 633
Output of pcretest -c:

Code:
PCRE version 8.10 2010-06-25
Compiled with
 UTF-8 support
 Unicode properties support
 Newline sequence is LF
 \R matches all Unicode newlines
 Internal link size = 2
 POSIX malloc threshold = 10
 Default match limit = 10000000
 Default recursion depth limit = 10000000
 Match recursion uses stack
phpinfo() says something interesting... PCRE Library Version: 3.9 02-Jan- 2002 and configure command: '--with-pcre-regex=/usr/local'

Any ideas? This is basically an unmodified machine with directadmin + custombuild. PhpMyAdmin for instance won't run. Thanks!
 

RivalMarco

Verified User
Joined
Jun 27, 2010
Messages
8
I have got the same problem, until today it worked fine, i am not exactly sure what specific update caused this error.

My server is running CentOS 5, Apache 2.0 and PHP 5.2, i tried rebuilding PHP with PHP 5.2 / 5.3, with and without an external PCRE Libary.. did not succeed.
 

Koradhil

New member
Joined
May 12, 2011
Messages
2
I'm having the same issue. I'm tried to do this:

First, install PCRE 8.12:
Code:
wget ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-8.12.tar.bz2
tar jxf pcre-8.12.tar.bz2 && cd pcre-8.12
./configure --prefix=/usr/local
make && make install
Now navigate to the custombuild directory:
Code:
cd /usr/local/directadmin/custombuild/
Modify options.conf. Under Custombuild options, set clean=yes and php5_ver=5.3
Now cleanup, update, build and restart:
Code:
./build clean
./build update
./build all y
/sbin/service httpd restart
I've used this before (with another server) and it worked fine, but this time it's not compiling with the right PCRE for some reason. phpinfo() shows pcre version 3.9 and --with-pcre-regex=/usr/local
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,759
Location
LT, EU
There is no need to reinstall PECL manually, because it's included into the CustomBuild script. Just execute the following to update it:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build pecl
You can reinstall PHP afterwards, if you need that:
Code:
./build php n
 

Koradhil

New member
Joined
May 12, 2011
Messages
2
Thanks. I figured it out already, it's working now.

What I did is edit /usr/local/directadmin/custombuild/configure/ap2/configure.php5
Change --with-pcre-regex=/usr/local to --with-pcre-regex

This will make the build script use the included version of pcre (which is 8.11 in my case).
 
Top