PHP 7.4 installation error

eva2000

Verified User
Joined
Jul 1, 2019
Messages
93
Might be specific issue with centos 6's krb5-devel missing corresponding *.pc files ?

centos 6 has
Code:
rpm -ql krb5-devel | egrep 'lib64|\.pc'
/usr/lib64/libgssapi_krb5.so
/usr/lib64/libgssrpc.so
/usr/lib64/libk5crypto.so
/usr/lib64/libkdb5.so
/usr/lib64/libkrb5.so
/usr/lib64/libkrb5support.so
centos 7 has
Code:
rpm -ql krb5-devel | egrep 'lib64|\.pc'
/usr/lib64/libgssapi_krb5.so
/usr/lib64/libgssrpc.so
/usr/lib64/libk5crypto.so
/usr/lib64/libkdb5.so
/usr/lib64/libkrad.so
/usr/lib64/libkrb5.so
/usr/lib64/libkrb5support.so
/usr/lib64/pkgconfig/gssrpc.pc
/usr/lib64/pkgconfig/kadm-client.pc
/usr/lib64/pkgconfig/kadm-server.pc
/usr/lib64/pkgconfig/kdb.pc
/usr/lib64/pkgconfig/krb5-gssapi.pc
/usr/lib64/pkgconfig/krb5.pc
/usr/lib64/pkgconfig/mit-krb5-gssapi.pc
/usr/lib64/pkgconfig/mit-krb5.pc
so for centos 6 with PHP 7.4 would need to use KERBEROS_CFLAGS and KERBEROS_LIBS environment variables to point PHP 7.4 to the right location for krb5 and krb5-gasspi

Code:
cat /usr/lib64/pkgconfig/krb5-gssapi.pc
prefix=/usr
exec_prefix=/usr
libdir=/usr/lib64
includedir=/usr/include
vendor=MIT

Name: krb5-gssapi
Description: Kerberos implementation of the GSSAPI
Version: 1.15.1
Requires: mit-krb5-gssapi
Code:
cat /usr/lib64/pkgconfig/krb5.pc
prefix=/usr
exec_prefix=/usr
libdir=/usr/lib64
includedir=/usr/include
vendor=MIT

defccname=FILE:/tmp/krb5cc_%{uid}
defktname=FILE:/etc/krb5.keytab
defcktname=FILE:/var/kerberos/krb5/user/%{euid}/client.keytab

Name: krb5
Description: An implementation of Kerberos network authentication
Version: 1.15.1
Requires: mit-krb5
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
670
Location
Murfreesboro
Ah I see.. no wonder. All the issues. I mean when a New restaurant opens in town... I never go until they have been open awhile. :)
 

stefantriep

Verified User
Joined
Dec 15, 2012
Messages
23
Location
Haarlem
I can imagine, but the client want's to test his project on PHP 7.4 asap, before the client of the client comes with issues.
Hope we all can help accomplish that PHP 7.4 will work on all DirectAdmin installs soon.
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
670
Location
Murfreesboro
I can imagine, but the client want's to test his project on PHP 7.4 asap, before the client of the client comes with issues.
Hope we all can help accomplish that PHP 7.4 will work on all DirectAdmin installs soon.
I hear ya. I also am glad you want to help.
 

eva2000

Verified User
Joined
Jul 1, 2019
Messages
93
Ah I see.. no wonder. All the issues. I mean when a New restaurant opens in town... I never go until they have been open awhile. :)
PHP 7.4 changed how it's detects extension dependencies with reliance on pkg-config see https://raw.githubusercontent.com/php/php-src/PHP-7.4/UPGRADING so directadmin needs to change the way it compiles PHP 7.4 as such :)

========================================
13. Migration to pkg-config
========================================

A number of extensions have been migrated to exclusively use pkg-config for the
detection of library dependencies. Generally, this means that instead of using
--with-foo-dir=DIR or similar only --with-foo is used. Custom library paths can
be specified either by adding additional directories to PKG_CONFIG_PATH or by
explicitly specifying compilation options through FOO_CFLAGS and FOO_LIBS.

The following extensions and SAPIs are affected:

- Curl:
. --with-curl no longer accepts a directory.

- Enchant:
. --with-enchant no longer accepts a directory.

- FPM:
. --with-fpm-systemd now uses only pkg-config for libsystem checks. The
libsystemd minimum required version is 209.

- GD:
. --with-gd becomes --enable-gd (whether to enable the extension at all) and
--with-external-gd (to opt into using an external libgd, rather than the
bundled one).
. --with-png-dir has been removed. libpng is required.
. --with-zlib-dir has been removed. zlib is required.
. --with-freetype-dir becomes --with-freetype.
. --with-jpeg-dir becomes --with-jpeg.
. --with-webp-dir becomes --with-webp.
. --with-xpm-dir becomes --with-xpm.

- IMAP:
. --with-kerberos no longer accepts a directory.

- Intl:
. --with-icu-dir has been removed. If --enable-intl is passed, then libicu is
always required.

- Ldap:
. --with-ldap-sasl no longer accepts a directory.

- Libxml:
. --with-libxml-dir has been removed.
. --enable-libxml becomes --with-libxml.
. --with-libexpat-dir has been renamed to --with-expat and no longer accepts a
directory.

- LiteSpeed:
. --with-litespeed becomes --enable-litespeed.

- Mbstring:
. --with-onig has been removed. Unless --disable-mbregex has been passed,
libonig is required.

- ODBC:
. --with-iodbc no longer accepts a directory.
. --with-unixODBC without a directory now uses pkg-config (preferred).
Directory is still accepted for old versions without libodbc.pc.

- OpenSSL:
. --with-openssl no longer accepts a directory.
. --with-kerberos no longer accepts a directory.

- PCRE:
. --with-pcre-regex has been removed. Instead --with-external-pcre is provided
to opt into using an external PCRE library, rather than the bundled one.

- PDO_SQLite:
. --with-pdo-sqlite no longer accepts a directory.

- Readline:
. --with-libedit no longer accepts a directory.

- Sodium:
. --with-sodium no longer accepts a directory.

- SQLite3:
. --with-sqlite3 no longer accepts a directory.

- XSL:
. --with-xsl no longer accepts a directory.

- Zip:
. --with-libzip has been removed.
. --enable-zip becomes --with-zip.
 

evathias

Verified User
Joined
Mar 18, 2019
Messages
14
Am I the only one on CentOS 6 with this issue? I can try it on a CentOS 7 test machine
Hello,

Through Custombuild 2.0 I have selected php 7.4 and it seems to work (sites are loading faster). Then, custombuild offers me an update (PHP 7.4 5.6.40 update to 7.4.0 is available ). When I try to update it, I get the same errors that are described in this post.
 

gurek

Verified User
Joined
Jul 15, 2009
Messages
5
Location
Poland
Hi,

PHP 7.4 from Custombuild don't have pecl?
/usr/local/php74/bin/pecl - not found
 
Top