PHP Selector for more than 2 PHP version

vahid07

Verified User
Joined
Apr 16, 2018
Messages
7
Hi,

its very good to have two php version in current directadmin but sometime we need more than 2 php version for our customers with old scripts. please add a feature which can use more than two php version with directadmin panel.

(i know we can run 3rd php manually but that way so difficult for most users)

Thank you
 

Arieh

Verified User
Joined
May 27, 2008
Messages
1,206
Location
The Netherlands
I would like to point out that this is possible with CloudLinux, they also patch older PHP versions no longer supported by PHP itself, so that they can be used safely even so.
 

Phuturist

Verified User
Joined
Dec 30, 2018
Messages
19
I'd can really use this as well. I would be willing to pay a little for custom development of this functionality.
 

Phuturist

Verified User
Joined
Dec 30, 2018
Messages
19
I think that this feature is on the way and will be avaible soon: https://directadmin.com/features.php?id=2243
The feature you linked to is already implemented but unrelated to this request. The implemented feature is about showing only one selector for available PHP versions for a domain. This selector can currently only have a maximum of 2 available PHP version. This request is being able to add more than 2 PHP version to select from through this selector.
 

webaltern

Verified User
Joined
Feb 10, 2008
Messages
173
Location
Québec, Canada
The feature you linked to is already implemented but unrelated to this request. The implemented feature is about showing only one selector for available PHP versions for a domain. This selector can currently only have a maximum of 2 available PHP version. This request is being able to add more than 2 PHP version to select from through this selector.
I know this feature is alreayd implemented. But it was a prerequise to get more than 2 PHP vesion with DA.

https://directadmin.com/features.php?id=2243 said:
CustomBuild 2.0 has the ability to support more than 2 php versions quite easily. The hold-back is the internal DirectAdmin code to manage php1 and php2 versions in the configs and templates.

........... If this all goes ahead, then CustomBuild 2.0 will then be changed to support php3_ php4_ etc, up to N version (any number), likely for php-fpm (mod_php can only be used once)
and this is why they have changed the way the form to select your php version works.
 

Phuturist

Verified User
Joined
Dec 30, 2018
Messages
19
Ok, that makes sense. Thank you for clairifying. It seems I have to be patiened until the "More DA changes will be needed for that later one, so this is more of a feeler for the proposed changes." have taken place and the feature of more PHP versions comes available. Do you know if there is seperate feature has been registered which I can track to follow progress?
 

Hosted Power

Verified User
Joined
Apr 13, 2018
Messages
5
Well we just need multiple php versions installed (> 2).

If there are for example 5 versions, we only would like to specify 1 per account. So we'd just need to be able to select a php1 (which can be any of the 5 versions installed).

Would this be possible today or still impossible?
 
Top