phpMyAdmin Error 500 Internal Server Error

HSG

Verified User
Joined
Oct 7, 2015
Messages
31
Create table with php code is ok but every do in phpMyAdmin show 500 error.
Please help me i only need this.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
9,449
Location
LT, EU
It might be the cause :) Try disabling it and check if it works then.
 

HSG

Verified User
Joined
Oct 7, 2015
Messages
31
It might be the cause :) Try disabling it and check if it works then.
Yes.
Thanks problem solved but why mod_security cause this?
This means I can't use mod_security? Why?
Can disable mod_security only for phpMyAdmin ?
Sorry for my bad english.
 

bibiugly

Verified User
Joined
Apr 9, 2019
Messages
20
Hi,

My vps configs is:
CentOS 6.7
DirectAdmin 1.48.3
Apache + NginX + PHP-FPM

After install all, when i want to create a table in phpMyAdmin show me error number 500 internal server error like this picture:
http://up.vbiran.ir/uploads/20448144421318020278_MyAdmin.jpg

Please help me and sorry for my
Default custombuild installation, mod_security rules installed in:

Code:
/etc/modsecurity.d/
Apache load’s ModSecurity modules and configuration in:

Code:
/etc/httpd/conf/extra/httpd-modsecurity.conf
Disable mod_security
Easiest way disable Modsecurity is disable apache to load ModSecurity module in https-modsecurity.conf file. Just add #comment’s to begin LoadModule directive:

Code:
httpd-modsecurity.conf
LoadFile /usr/local/lib/libxml2.so
#LoadModule security2_module /usr/lib/apache/mod_security2.so
<ifmodule mod_security2.c>
    # Default recommended configuration
    SecRuleEngine On
    SecRequestBodyAccess On
    .
    .
    .
</ifmodule>
SecRuleEngine
Another method if you wanna keep ModSecurity module loaded to apache is change SecRuleEngine to Off

Code:
SecRuleEngine Off
Then restart the web service.
 
Top