phpMyAdmin not accepted file size in phjp.ini

shanky

Verified User
Joined
Dec 7, 2007
Messages
60
Max File size in phpmyadmin is 2MB (Max: 2,048KiB)

max_file_size.jpg

/usr/local/php56/lib/php.ini has concerening values as follows:

Server is VPS :
--------------------------
upload_max_file_size = 64M
post_max_size = 65M
memory_limit =512M
max_execution_time = 300
-----then---
systemctl restart php-fpm56
systemctl restart httpd
--------------------------

Anyway, the max value in phpMyAdmin is not changed.

Please avdvice how I can change the Upload Max File Size in phpMyAdmin.

Regards
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,510
Location
LT, EU
Please check the output of:
Code:
php --ini
Some of the settings are defined in 50-webapps.ini, but not the ones your specified :) If you'd like edit other settings, and file not to get overridden with updates, you should place a copy of it here: /usr/local/directadmin/custombuild/custom/custom/php.conf.d/50-webapps.ini.

Otherwise, you may just create 99-custom.ini or something like it, with settings overwriting the defined ones. For example:
Code:
upload_max_file_size = 64M
post_max_size = 65M
memory_limit = 512M
max_execution_time = 300
However, I think your problem is elsewhere. Please make sure you have a correct php.ini file edited, no duplicate lines etc. Place phpinfo() page to check the settings set.

Thank you!
 

shanky

Verified User
Joined
Dec 7, 2007
Messages
60
Thank so much. Your suggestion help me to fix it. This is the result:

1. All modification in all php (5.3,5.6,7.1,7.3) are failed when working with php.ini of each version. There is no duplication of each value in the main php.ini.
2. All modification with file 50-webapps.ini is failed either.
3. Fixed when Modify /usr/local/php56/lib/php.conf.d/10-directadmin.ini and the ohter php versions.

nano /usr/local/php71/lib/php.conf.d/10-directadmin.ini
.....
post_max_size = 65M
upload_max_filesize = 64M
memory_limit = 512M
max_execution_time = 300
Thanks & Best Regards
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,510
Location
LT, EU
It'd get overridden too, please use 99-custom.ini or any other name, this should work :)
 
Top