Problem POP3 not works

NovaWebSE

Verified User
Joined
Jan 23, 2014
Messages
36
Good morning,
these days I have installed on a VPS DA, everything works but the mail does not want to know.
The situation is very strange, and I don't know how to proceed.

ssl creation:
openssl req -new -newkey rsa: 2048 -nodes -keyout server.key -out server.csr

imap works and I send mail with SSL automatically, perfect. example

imap.server.com 993 SSL
mx.server.com 465 SSL

Pop3 not function does not accept the settings and is unable to send mail.

pop.server.com 995 SSL
mx.server.com 465 SSL

by mistake and does not want to know

if i use this setting same error

pop.server.com 110 STARTTLS
mx.server.com 465 SSL

Failed to authenticate on the server, the configuration, username and password may be incorrect

Some ideas please
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Hello,

- Does it work in RoundCube?
- Does it work from another device, mail program?

We use

- IMAP 143 with SSL/TLS
- SMTP 587 with SSL/TLS
- POP3 110 with SSL/TLS
 

NovaWebSE

Verified User
Joined
Jan 23, 2014
Messages
36
Solved and discovered the problem.
I had written badly in the dovecot conf /ssl.conf file
Badly read the certificate ..
I have no words. Sorry
 

sufiyanshaikh

Verified User
Joined
Aug 14, 2019
Messages
69
Solved and discovered the problem.
I had written badly in the dovecot conf /ssl.conf file
Badly read the certificate ..
I have no words. Sorry
Can you please explain what exactly was the issue?
What was written badly in dovecot conf /ssl.conf file ?
 

NovaWebSE

Verified User
Joined
Jan 23, 2014
Messages
36
of course,
I have encountered two problems, given that I use a multi certificate for centralized mail management.
when you receive a certificate you cannot rename it creates problems.
You must always use cat mx.mydomain.com.key > server.key
Using a centralized certifcate it works for all associated ip.
so in /etc/dovecot/conf/ssl.conf paste path:

ssl_cert = </etc/dovecot/xxx/server.crt
ssl_key = </etc/dovecot/xxx/server.key

ssl_dh = </etc/dovecot/dh.pem

ssl_min_protocol = TLSv1
ssl_cipher_list = ALL:! ADH: RC4 + RSA: + HIGH: + MEDIUM: -LOW: -SSLv2: -EXP

Second problem:
I had gone the wrong way of exim
Same for exim but differently:

openssl_options = + no_sslv2 + no_sslv3
tls_require_ciphers = ALL:! ADH: RC4 + RSA: + HIGH: + MEDIUM: -LOW: -SSLv2: -EXP
tls_certificate = /etc/dovecot/xxx/server.crt
tls_privatekey = /etc/dovecot/xxx/server.key

I hope it helps
 
Top