Problem with building Comodo ModSecurity Rule Set

apogee

Verified User
Joined
Jul 6, 2019
Messages
28
Hello

Maybe a stupid question, I'm in the process to migrate to DA and learning how to work with the system.
I tried to install mod_sec to prepare the server for production. I get this error:

Code:
Executing /usr/local/directadmin/plugins/custombuild/admin/build modsecurity_rules...
Installing Comodo Rule Set for ModSecurity...
--2019-09-19 08:38:01-- https://waf.comodo.com/cpanel/cwaf_client_install.sh
Resolving waf.comodo.com (waf.comodo.com)... 178.255.86.135
Connecting to waf.comodo.com (waf.comodo.com)|178.255.86.135|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 757075 (739K) [text/x-sh]
Saving to: 'cwaf_client_install.sh'
0K .......... .......... .......... .......... .......... 6% 534K 1s
50K .......... .......... .......... .......... .......... 13% 1.53M 1s
100K .......... .......... .......... .......... .......... 20% 1.55M 1s
150K .......... .......... .......... .......... .......... 27% 1.56M 1s
200K .......... .......... .......... .......... .......... 33% 1.59M 0s
250K .......... .......... .......... .......... .......... 40% 32.0M 0s
300K .......... .......... .......... .......... .......... 47% 1.64M 0s
350K .......... .......... .......... .......... .......... 54% 17.0M 0s
400K .......... .......... .......... .......... .......... 60% 1.73M 0s
450K .......... .......... .......... .......... .......... 67% 22.3M 0s
500K .......... .......... .......... .......... .......... 74% 10.3M 0s
550K .......... .......... .......... .......... .......... 81% 2.02M 0s
600K .......... .......... .......... .......... .......... 87% 28.7M 0s
650K .......... .......... .......... .......... .......... 94% 39.9M 0s
700K .......... .......... .......... ......... 100% 5.14M=0.3s
2019-09-19 08:38:01 (2.24 MB/s) - 'cwaf_client_install.sh' saved [757075/757075]
Verifying archive integrity... All good.
Uncompressing Comodo WAF Client Installer v2.24.3 (build 1)................................................................................................................................................................................................................................
------------------------------------------------------
Checking pre-requisites
------------------------------------------------------
BASH bin OK (/bin/bash)
CPAN bin OK (/bin/cpan)
GCC bin OK (/bin/gcc)
MAKE bin OK (/bin/make)
STRINGS bin OK (/bin/strings)
------------------------------------------------------
Running installer
------------------------------------------------------
| LOG : Starting the installation
+------------------------------------------------------
| Greetings!
| This is a Comodo WAF Installation script.
| If you encounter any errors during the installation,
| you may examine log file /tmp/cwaf_install.log.13401 for more info.
+------------------------------------------------------
| LOG : ----------------Checking Apache-----------------------
| LOG : Found APACHE2CTL '/usr/sbin/apachectl'
| LOG : Found APACHE version 2.4.41
| LOG : No MODSECURITY detected
+------------------------------------------------------
| No installed ModSecurity for Apache found
+------------------------------------------------------
| LOG : ---------------Checking LiteSpeed---------------------
| LOG : LiteSpeed binary /usr/local/lsws/bin/lshttpd not found!
+------------------------------------------------------
| Not found LiteSpeed web server with mod_security enabled
+------------------------------------------------------
| LOG : -----------------Checking Nginx-----------------------
| LOG : Nginx binary /usr/local/nginx/sbin/nginx not found!
+------------------------------------------------------
| Not found Nginx web server with mod_security enabled
+------------------------------------------------------
| LOG : ------------------------------------------------------
ERROR: Not found mod_security, exiting
Can't open /etc/cwaf/main.conf: No such file or directory.
Can't open /etc/cwaf/main.conf: No such file or directory.
/usr/local/directadmin/custombuild/build: line 18853: /usr/local/cwaf/scripts/updater.pl: No such file or directory
Defaulting to Comodo WAF SecDefaultAction...
Installation of ModSecurity Rule Set has been finished.
Done!
How can I solve this?

In cpanel we’ve a mod_sec log viewer to see what happened, is this also possible in DA?

Thanks!
 

apogee

Verified User
Joined
Jul 6, 2019
Messages
28
I've solved it, looks like modsec hasn't been installed automatically by CustomBuild, I assumed that if activated, it would be installed automatically, why wasn't this the case? I don't know.

Problem solved with:
Code:
cd /usr/local/directadmin/custombuild
./build modsecurity
 
Top