Problem with ionCube loader

JohnyByk

Verified User
Joined
Mar 7, 2012
Messages
221
Hi.

I have compiled 4 versions of PHP.

When i do
Code:
 ./build/versions
i see this:
Code:
Latest version of ionCube: 10.3.2
Failed loading /usr/local/lib/ioncube/ioncube_loader_lin_5.3.so: /usr/local/lib/ioncube/ioncube_loader_lin_5.3.so: undefined symbol: execute
Failed loading /usr/local/lib/php/extensions/no-debug-non-zts-20090626/opcache.so: / usr / local / lib / php / extensions / no-debug-non-zts-20090626 / opcache. so: undefined symbol: compiler_globals
[B]ionCube loader 0 to 10.3.2 update is available.[/B]
It looks like "something" want to load ioncube loader for PHP 5.3?
Im not using this PHP version:
Code:
 ./build options | grep ^ PHP
PHP (default): 7.1 as php-fpm
PHP (additional): 5.4 as php-fpm
PHP (additional): 5.5 as php-fpm
PHP (additional): 5.6 as php-fpm
Maybe someone know where the problem is?

Regards
 
Last edited:

JohnyByk

Verified User
Joined
Mar 7, 2012
Messages
221
I found the solution. I commented old extension in php.ini but this "error" still exist.
/usr/local/directadmin/custombuild/build versions|grep ionCube
Latest version of ionCube: 10.3.2
Code:
[B]ionCube loader 0 to 10.3.2 update is available.[/B]
./build ioncube doesn't helps.
You think so it's problem with custombuild or with my configuration?

Now i have two versions of PHP runned 5.4 and 7.1 but in system default is 5.5
Code:
php -v
PHP 5.5.38 (cli) (built: Jan 25 2019 21:19:57)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies
Maybe that is the problem?
How to change default php version? I can't run ./build php because PHP 5.4 doesn't compile properly in debian 9.

Regards
 
Top