ProFTPd 1.3.6 public_html symbolic link no longer valid

nostech

Verified User
Joined
Jun 5, 2009
Messages
37
Today, I updated to ProFTPd 1.3.6 using DA custombuild.
Now when I try to connect via ftp the symbolic links are no longer recognized (they are shown as files and nothing can be done with them). This problem is equal to the problem described in http://forum.directadmin.com/showthread.php?t=42402 and https://forum.directadmin.com/showthread.php?t=49714

I have tried all the proposed solutions, but none are working for me. Anyone else having this problem or any additional suggestions in order to have this issue fixed?

Thank you in advance!

Update: I found out that this problem happens when using public_html/ as external folder (in this case public_html is a symlink), when using a subfolder of the symlink for example public_html/a_folder then suddenly all is working fine for some reason...
 
Last edited:

Driesp

Verified User
Joined
Mar 12, 2007
Messages
80
I have downgraded to 1.3.5e.
It contains the same CVE fix, and symlinks are working.
 

nostech

Verified User
Joined
Jun 5, 2009
Messages
37
That was my idea as well (since there were no actual replies on this thread) and since I noticed that (CVE fix) too on the ProFTPd website.

Only may I ask, how you were able to tell custombuild to use version 1.3.5e instead of 1.3.6?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,902
Location
GMT +7.00
To downgrade ProFTPd to 1.3.5 run this:

Code:
cd /usr/local/directadmin/custombuild
echo "proftpd:1.3.5:" >> custom_versions.txt
./build update
./build clean
./build proftpd
 

nostech

Verified User
Joined
Jun 5, 2009
Messages
37
Thanks zEitEr!

Also for people on CB 1.1/1.2:
Code:
cd /usr/local/directadmin/custombuild
./build set autover no
vi versions.txt
replace
Code:
proftpd:1.3.6:13270911c42aac842435f18205546a1b
with
Code:
proftpd:1.3.5:
Next
Code:
./build update_data
./build proftpd
 

Driesp

Verified User
Joined
Mar 12, 2007
Messages
80
Pay attention! These are different versions.
You need to install proftpd 1.3.5e!

It should be:
Code:
proftpd:1.3.5e:0df72d7bb47e1918c3bfced5cc852e71
Also this version is nowhere to be found on the directadmin mirrors,
you need to download it manually from the proftpd ftp server in the custombuild directory.
Code:
wget "ftp://ftp.proftpd.org/distrib/source/proftpd-1.3.5e.tar.gz"
Then compile with
Code:
./build proftpd
 
Top