pure-ftpd to proftpd problem

myH2Oservers

Verified User
Joined
Mar 13, 2006
Messages
243
Location
Netherlands
I just found out I was missing /var/log/proftpd too, on a new CentOS 8 install that I did last week. Does the fix also apply to new installs (and not converts from pureftp)?
 

Hosted Power

Verified User
Joined
Apr 13, 2018
Messages
7
So NoSessionReuseRequired should be set automatically now? Anything we need to configure to make this happen? Or how do we get this going?

Just had a customer who had this problem... :)
 

Hosted Power

Verified User
Joined
Apr 13, 2018
Messages
7
just had another one today, seems like quite a widespread problem. What's the best option to get this fixed "by default"? :)
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
1,306
Location
Murfreesboro
So NoSessionReuseRequired should be set automatically now
If you mean this not sure that is what Smtalk was referring too.
It's hard to tell. Did you try this?

Try adding this line at the end:
Code:
TLSOptions NoSessionReuseRequired
That will take care of this errror:
Code:
2020-04-19 20:32:10,781 mod_tls/2.7[1927]: starting TLS negotiation on data connection
2020-04-19 20:32:10,793 mod_tls/2.7[1927]: client reused SSL session for data connection
2020-04-19 20:32:10,794 mod_tls/2.7[1927]: Client did not reuse SSL session from control channel, rejecting data connection (see the NoSessionReuseRequired TLSOptions parameter)
2020-04-19 20:32:10,794 mod_tls/2.7[1927]: unable to open data connection: TLS negotiation failed
This is because your FTP client is using another SSL session for the data connection (which seems to be pretty common) I always add that line when I update proftpd in my machines to fix it.
 
Top