[Release] Exim Editor - No-Cost!

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey,

This is to let everyone know we have decided to release Exim Editor at no-cost.

I do want to thank all those who have purchased copies of Exim Editor as it is because of your help that we are able to release it now at no-cost. Thank You!

As with most plugins you can go to the Plugin Manager and use the following URL to grab and install the plugin:

http://files.mysiteplugins.com/Exim_Editor.tar.gz

If you are currently running Exim Editor you should see a new version available. Once you upgrade you will no longer see the License Details.

Hopefully this will be of benefit to the DirectAdmin community.

Thanks, David
 

GXX

Verified User
Joined
Mar 25, 2006
Messages
361
Getting an error upon installation:

Code:
Site error: the file /usr/local/directadmin/plugins/Exim_Editor/admin/index.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.
I do have Ioncube installed:

Code:
This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
    with eAccelerator v0.9.5.2, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
 

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey,

The plugin looks for the loaders in the ioncube directory that the plugin is in...

/usr/local/directadmin/plugins/Exim_Editor/ioncube

There's a downloader.php file in the /usr/local/directadmin/plugins/Exim_Editor/scripts directory that should take care of that...

Are the loaders in that directory? Also, what OS are you using?

Thanks, David
 

GXX

Verified User
Joined
Mar 25, 2006
Messages
361
The ioncube files were not there.

I ran the downloader.php file manually and it downloaded the files. It seems when installing, this step isn't done correctly.

The plugin now works.

OS: CentOS
 

morfargekko

Verified User
Joined
Oct 21, 2007
Messages
188
I have a problem with this and I am getting errors:
[root@abra scripts]# /usr/local/directadmin/plugins/Exim_Editor/scripts/install.sh
cp: cannot stat `/usr/local/directadmin/plugins/Exim_Editor/sources/wrapper-exim-linux': No such file or directory
Preferences Maintained.
<PRE>
Attempting to Download the ionCube Loaders
Site error: the file <b>/usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php</b> requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.Setting Permissions...
Permissions Successfully Set!
Creating a Backup of exim.conf...
Exim Editor Plugin Successfully Installed!
</PRE>

I have the ionCube files in place so what?
OS = CentOS 5
 

morfargekko

Verified User
Joined
Oct 21, 2007
Messages
188
OK I managed to get it to work by running:
php /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php

But I get the following errors:

Warning: exec() has been disabled for security reasons in /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php(0) : eval()'d code on line 1

Warning: Invalid argument supplied for foreach() in /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php(0) : eval()'d code on line 1
ionCube Loaders Successfully Downloaded!

What to do if anything? :confused:
 

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey,

The ioncube files were not there.

I ran the downloader.php file manually and it downloaded the files. It seems when installing, this step isn't done correctly.

The plugin now works.

OS: CentOS
I'll get that looked at... It's possible something changed in that file in the latest code... Just a guess.

Thanks, David
 

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey,

OK I managed to get it to work by running:
php /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php

But I get the following errors:

Warning: exec() has been disabled for security reasons in /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php(0) : eval()'d code on line 1

Warning: Invalid argument supplied for foreach() in /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php(0) : eval()'d code on line 1
ionCube Loaders Successfully Downloaded!

What to do if anything? :confused:
It appears as though you have PHP Safe mode enabled... Is that true?

Thanks, David
 

mmerlin

Verified User
Joined
Jul 26, 2004
Messages
68
Location
Melbourne, Australia
we have decided to release Exim Editor at no-cost.
Wow amazing!

I've found the Exim Editor to be of great help in the year or more that I've been using it, well worth the purchase price.

You guys should consider having an option for donations or something.

Put up a link to your PayPal account (and/or links to your favorite charities) for those who want to give thanks and chip in for all your effort and hard work.

Kudos in getting this great piece of software out to the DA admins of the world!
 

kerrle

New member
Joined
Feb 27, 2006
Messages
3
I have safe_mode set to off.
Even if you have safe mode turned off, you could still get this error if you had exec listed in your "disable_functions" in php.ini. The Easy Linux Security script posted here in this forum offers to do this.

You'll need to enable this function to install and use Exim Editor, as it has to be able to modify your Exim configuration files.
 

RadMan

Verified User
Joined
Apr 12, 2007
Messages
209
Location
Canada
David.. We had the same issue a couple of months ago..

http://www.directadmin.com/forum/showthread.php?t=16451&page=4

I just updated also and am back in the same boat with the same error..

Running CentOS release 4.5 and PHP 5.2.5

Code:
 Site error: the file /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.
 

morfargekko

Verified User
Joined
Oct 21, 2007
Messages
188
Even if you have safe mode turned off, you could still get this error if you had exec listed in your "disable_functions" in php.ini. The Easy Linux Security script posted here in this forum offers to do this.

You'll need to enable this function to install and use Exim Editor, as it has to be able to modify your Exim configuration files.
I feel that enabeling exec is bad for security.
The plugin seams to work now so everyting is ok.

Thanks anyway.
 

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey,

David.. We had the same issue a couple of months ago..

http://www.directadmin.com/forum/showthread.php?t=16451&page=4

I just updated also and am back in the same boat with the same error..

Running CentOS release 4.5 and PHP 5.2.5

Code:
 Site error: the file /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.
Can you try to run the downloader.php file (as root, in the scripts directory under Exim_Editor) and let me know what happens...

I think the issue we're seeing now is with that file...

Thanks, David
 

skruf

Verified User
Joined
Jun 3, 2004
Messages
680
Location
US
Hey,

I feel that enabeling exec is bad for security.
The plugin seams to work now so everyting is ok.

Thanks anyway.
Well, unfortunately my programmer tells me that needs to be enabled for Exim Editor to do it's job.

Thanks, David
 

andyreed

Verified User
Joined
Nov 28, 2004
Messages
273
Location
Minneapolis, MN
Site error: the file /usr/local/directadmin/plugins/Exim_Editor/scripts/downloader.php requires the ionCube PHP Loader ioncube_loader_lin_5.2.so to be installed by the site administrator.
If ionCube is installed and activated on your server, you don't need to install it again for Exim Editor. To solve this issue with Exim Editor, do the following:

Assuming the local path for ionCube is: /usr/local/ioncube/
using your favorite Linux editor such as vi or pico, edit the file php.ini that comes with Exim Editor:
vi /usr/local/directadmin/plugins/Exim_Editor/data/php.ini
Add the following directive and then save the file:

zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so

Make sure ionCube is activated with your Php by running this command:
php -v
you should see:
Code:
PHP 5.2.5 (cli) (built: Feb  1 2008 18:20:14) 
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.2.8, Copyright (c) 1998-2007, by Zend Technologies
 

RadMan

Verified User
Joined
Apr 12, 2007
Messages
209
Location
Canada
Hi Andy.. Your talking to a total novice here,,'

I've opened the file but have no idea where to insert that directive... :(

Ed

If ionCube is installed and activated on your server, you don't need to install it again for Exim Editor. To solve this issue with Exim Editor, do the following:

Assuming the local path for ionCube is: /usr/local/ioncube/
using your favorite Linux editor such as vi or pico, edit the file php.ini that comes with Exim Editor:
vi /usr/local/directadmin/plugins/Exim_Editor/data/php.ini
Add the following directive and then save the file:

zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so

Make sure ionCube is activated with your Php by running this command:
php -v
you should see:
Code:
PHP 5.2.5 (cli) (built: Feb  1 2008 18:20:14) 
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.2.8, Copyright (c) 1998-2007, by Zend Technologies
 

RadMan

Verified User
Joined
Apr 12, 2007
Messages
209
Location
Canada
Picked a spot and inserted anyway... Still not working..

Ed

If ionCube is installed and activated on your server, you don't need to install it again for Exim Editor. To solve this issue with Exim Editor, do the following:

Assuming the local path for ionCube is: /usr/local/ioncube/
using your favorite Linux editor such as vi or pico, edit the file php.ini that comes with Exim Editor:
vi /usr/local/directadmin/plugins/Exim_Editor/data/php.ini
Add the following directive and then save the file:

zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so

Make sure ionCube is activated with your Php by running this command:
php -v
you should see:
Code:
PHP 5.2.5 (cli) (built: Feb  1 2008 18:20:14) 
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with the ionCube PHP Loader v3.1.32, Copyright (c) 2002-2007, by ionCube Ltd., and
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.2.8, Copyright (c) 1998-2007, by Zend Technologies
 

RadMan

Verified User
Joined
Apr 12, 2007
Messages
209
Location
Canada
Dave.. Can you give me some explicit commands to "run the downloader.php file"

Cheers

Ed

Hey,



Can you try to run the downloader.php file (as root, in the scripts directory under Exim_Editor) and let me know what happens...

I think the issue we're seeing now is with that file...

Thanks, David
 
Top