roundcube password change error - DA appears to be using SSL. Change your script to connect to ssl:


Verified User
May 3, 2016
Hi all,

Getting strange error if users try to change PW in roundcube (as shown in subject). Any ideas? I have Let's Encrypt running for the server which is all fine and good, can send and receive email, but if a user tries to change their PW - they get that error and it does not change?

Oh and I see these in the DA error.log:

2020:05:28-14:21:31: Can't connect to ssl!
2020:05:28-14:22:30: Can't connect to ssl!
2020:05:28-14:27:30: Can't connect to ssl!
2020:05:28-14:28:10: Can't connect to ssl!
2020:05:28-14:36:20: Can't connect to ssl!
2020:05:28-14:41:10: Can't connect to ssl!

I've found my answer by smtalk in this thread:

But if ssl:// is also working it's fine by me too. I had to change an account creation script which works via api to ssl:// to get it to work.
I have option already for : email_ftp_password_change=1

get the same case, when use change password via roundcube, error :
DirectAdmin appears to be using SSL. Change your script to connect to ssl://

/var/log/directadmin/error.log >> Can't connect to ssl!

CloudLinux release 8.1
just test with roundcube RELEASE 1.3.6, it works, but no clue for the latest roundcube version
Today I ran also in this problem and email_ftp_password_change=1 was already in the directadmin.conf file. I solved it by changing the Roundcube configuration file /var/www/html/roundcube/plugins/password/

Change this line:

$config['password_directadmin_host'] = 'tcp://localhost';


$config['password_directadmin_host'] = 'ssl://localhost';

in the DirectAdmin driver options. This solved it for me. I just have to keep an eye to it that the next update doesn't overwrite this change.

I just mention this here for if somebody also encounters this issue.