Server (:2222) SSL is used instead of users

Status
Not open for further replies.

thomasdk81

Verified User
Joined
Oct 3, 2010
Messages
56
Location
Denmark
Hi guys,

I've setup Let's Encrypt and generated the certificate for server hostname :)2222).
This works great.

I've enabled SSL on a user and generated the certificate in the GUI. This is done succesfully.

But when I check the users https://domain. The server hostname certificate is used.
Somehow the user certificate is overruled.

Example: https://infolandcms.dk/ (SSL Server Test: https://www.ssllabs.com/ssltest/analyze.html?d=infolandcms.dk&hideResults=on )

Hoping you can help me, I have tried everything.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
Hello,

Make sure Apache was restarted. Probably you need to do it in a root console.
 

thomasdk81

Verified User
Joined
Oct 3, 2010
Messages
56
Location
Denmark
I don't use named on the server, I use an external provider for DNS.
Could that be a/the problem?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
Hardly name can be an issue here.

If it's possible I'd like to check it from inside, send me PM with admin level access into Directadmin and I will check it for you. Alternatively you could post here a screenshot of a page with SSL settings of one of the domains and virtualhost's config from apache.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
Thomas,

You are running Apache/2.4.16 (Unix) OpenSSL/0.9.8e-fips-rhel5 on CentOS 5, you need to upgrade OpenSSL (a OS version upgrade would be even better) as your current version does not support SNI.
 

mediacs

New member
Joined
Dec 11, 2019
Messages
10
same issue here, hostname gets assigned to LE certificate in stead of the domainname.
Some background information: my vps provider said I had to add this to my directadmin.conf to enable let's encrypt:

SSL=1
carootcert=/usr/local/directadmin/conf/carootcert.pem
force_hostname=server.jedomein.nl
ssl_redirect_host=server.jedomein.nl
enable_ssl_sni=1
mail_sni=1
letsencrypt=1

and use this command (so that the cert doesnt get assigned to 'localhost'):
cd /usr/local/directadmin/scripts
./letsencrypt.sh request_single server.jedomein.nl

OK, I get a ssl lock in de addressbar when logged in directadmin. But I really wanted the ssl for the domains on this server to work, and that doesn't.
 

mediacs

New member
Joined
Dec 11, 2019
Messages
10
I'm sorry, I can't see how this is a solution to my problem?
My problem is that the certificates on the user domains all get the hostname server.mediacs.nl.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
Purely taking the topic subject and your description I've made a conclusion you want to connect securely to DirectAdmin on port 2222 using users domains. If my assumption is wrong, then you need to search for another solution.

Meanwhile, please do not double post. I see you've already reported this issue in another thread. You should stick to one thread.
 
Status
Not open for further replies.
Top