setup.sh FreeBSD Version Detection Improvement for Jails

ChiefZigZag

Verified User
Joined
Feb 17, 2020
Messages
31
I see on the setup.sh that the script currently uses uname -a to determine the FreeBSD version. There is a scenario where a user could use FreeBSD jails to run a previous version of FreeBSD for a directadmin deployment. There might be a better way to determine the version so as to support FreeBSD jails. I am using iocage at the moment, and I attempted to run 11.3 on my 12.1 host for troubleshooting and it didn't work without editing the script.
 
Top