SMTP/IMAP Connections failing

jayw1

Verified User
Joined
Nov 20, 2019
Messages
157
Location
USA
Hi,

I'm trying to add my email accounts into an Android app.
I have tried so many combinations of ports, SSL/STARTTLS/No Encryption. Nothing works. It always times out when trying to connect.
All the ports I have tried are open via CSF and I have also tried with CSF disabled.
The settings I use:

Hostname: mail.domain.com
Username: username@domain.com
Password: password

What is going wrong?
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,554
Location
Maastricht
Hard to say, especially without real domain info we can test on.
I suggest you first try to connect on a pc/laptop/mac with a normal e-mail client and see if that works like it should.
And try with telnet locally if things are running correctly.
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
157
Location
USA
I can't log in to any email account unless I'm using Roundcube.
 

network

Verified User
Joined
Jul 7, 2019
Messages
46
Do you was try with thunderbird / outlook in your computer for make sure if any different with your android phone ?

i have same case like you few month ago if we used google dns in our phone we cant connect or add mail in android but if used standard dns carrier operator it work.
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
157
Location
USA
Do you was try with thunderbird / outlook in your computer for make sure if any different with your android phone ?

i have same case like you few month ago if we used google dns in our phone we cant connect or add mail in android but if used standard dns carrier operator it work.
I don't have Outlook/Thunderbird, not a Windows user.
Interesting, I use Cloudflare's 1.1.1.1 on my phone and desktop, will test without.
 

jayw1

Verified User
Joined
Nov 20, 2019
Messages
157
Location
USA
Fixed!

I was proxying mail.domain.com through CloudFlare. Turn the orange cloud off!
 
Top