(Solved) - Office 365 problem

dirux

Verified User
Joined
Dec 28, 2019
Messages
18
Hi,
I have to try to set up an office 365 for a domain with the "MX Records". I have also trying to use Gmails set up for a domain and here all works okay. I can see in the DNS that the "local mail" switch to no and all work fine!

But for office 365 just 1 records for the domain-se.mail.protection.outlook.com com in. All the other records don't and the local mail is still "on". This is making some problem for me because all the "local" mails that send to domain.se is going to the local server and not com to my Office 365 account.

What we notice that no mails can be sent from the "local mail domains" in the server. We just got a PTR records error...

Our named file is look like this.

domain.se. 3600 IN MX 0 domain-se.mail.protection.outlook.com.


_acme-challenge-test 3600 IN TXT "pre-check"
 

scriptkitty

Verified User
Joined
Jul 10, 2019
Messages
154
You can manually turn off local mail. There is a checkbox if you visit the section to configure MX record.

Also, you could just remove the domain from the local domains file: /etc/virtual/domains
 

dirux

Verified User
Joined
Dec 28, 2019
Messages
18
You can manually turn off local mail. There is a checkbox if you visit the section to configure MX record.

Also, you could just remove the domain from the local domains file: /etc/virtual/domains
Thanks! - This help me to solved the problem!!
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,482
Location
Maastricht
At the page where the checkbox is, you can also setup Gmail Suite or Office 365 on the pulldown below.
This will make all the necessary DNS records for you, so you won't forget any (including adding gmail or outlook to SPF).
 

npc

Verified User
Joined
May 21, 2020
Messages
19
After changing a DNS server domain for Office 365, everything works fine.
But, I have a problem if from that domain Exchange sends an email to one that is on the same hosted server, it never arrives and does not give any error anywhere.

Did you come up with something?

NOTE: I have the MX Records option disabled: "Use this server to handle my ..."

Thank you.
 
Top