Spam not deleted

neo-hippie

Verified User
Joined
May 27, 2014
Messages
64
Location
The Netherlands (Holland)
Hello,

i've enabled spamassasin recently.
but spam isn't deleted if it's higher than i've setup.
email containes the required spam flags. so spamassasin is working:
Code:
X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on
 server.neo-hippie.net
X-Spam-Flag: YES
X-Spam-Level: *****************
X-Spam-Status: Yes, score=17.1 required=5.0 tests=DKIM_ADSP_CUSTOM_MED,
 FREEMAIL_FROM,NML_ADSP_CUSTOM_MED,RAZOR2_CF_RANGE_51_100,
 RAZOR2_CF_RANGE_E8_51_100,RAZOR2_CHECK,RCVD_IN_BL_SPAMCOP_NET,
 RCVD_IN_BRBL_LASTEXT,RCVD_IN_MSPIKE_BL,RCVD_IN_MSPIKE_L5,RCVD_IN_PSBL,
 RCVD_IN_RP_RNBL,RDNS_NONE,SPF_HELO_SOFTFAIL,SPF_SOFTFAIL,T_HTML_ATTACH,
 T_OBFU_HTML_ATTACH autolearn=no autolearn_force=no version=3.4.0
on user level spamassasin setup:
Where do you want the spam to go? Delete the spam.
What score threshold do you wish to use? Low Threshold (5.0)
Would you like to delete high scoring spam? Yes, block all spam scoring higher than 15
Do you wish to rewrite the subject of a spam email? No, leave the subject unchanged.
How should the spam be deliverd? Use attachements.

now spam is detected, no problem. but i do still receive the emails in my inbox.
as an attachment with the complete spamassasin test report.

so how can i get spamassasin / exim to delete spam higher than say 15, and change the subject of email higher than 5?
 
Last edited:

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,901
Location
GMT +7.00
Hello,

That should be deleted, if it's not, then you need to check logs: both exim and spamd (you need find them in system logs or configure to log them into a separate file).
 

neo-hippie

Verified User
Joined
May 27, 2014
Messages
64
Location
The Netherlands (Holland)
Hello,

I have checked the logs
/var/log/exim/main.log (onley display's authentication and mail delivery)
Code:
2014-10-26 23:32:10 1XiWM5-0005Y8-Jc <= mike.sfsd4f564s6df45dseano@gmail.com H=(gmail.com) [119.196.23.254] P=smtp S=2053 id=A6DA0E4F.7EC69D6D@gmail.com T="Cheap and permanent Twitter Followers" from <mike.sfsd4f564s6df45dseano@gmail.com> for sales@nijboer.it
2014-10-26 23:32:11 1XiWM6-0005YD-Df <= mike.sfsd4f564s6df45dseano@gmail.com U=mail P=spam-scanned S=6538 id=A6DA0E4F.7EC69D6D@gmail.com T="Cheap and permanent Twitter Followers" from <mike.sfsd4f564s6df45dseano@gmail.com> for sales@nijboer.it
2014-10-26 23:32:11 1XiWM6-0005YD-Df => arnold <sales@nijboer.it> F=<mike.sfsd4f564s6df45dseano@gmail.com> R=virtual_user T=virtual_localdelivery S=6667
2014-10-26 23:32:11 1XiWM6-0005YD-Df Completed
2014-10-26 23:32:11 1XiWM5-0005Y8-Jc => sales <sales@nijboer.it> F=<mike.sfsd4f564s6df45dseano@gmail.com> R=spamcheck_director T=spamcheck S=6421
2014-10-26 23:32:11 1XiWM5-0005Y8-Jc Completed
Than checked /var/log/mail.err. says nothing about this mail.
Than checked /var/log/syslog which says the same as /var/log/mail.log
Code:
Oct 26 23:32:10 server spamd[19121]: spamd: connection from ip6-localhost [::1]:58050 to port 783, fd 6
Oct 26 23:32:10 server spamd[19121]: spamd: setuid to nijboer01 succeeded
Oct 26 23:32:10 server spamd[19121]: spamd: processing message <A6DA0E4F.7EC69D6D@gmail.com> for nijboer01:1008
Oct 26 23:32:11 server spamd[19121]: spamd: identified spam (17.1/5.0) for nijboer01:1008 in 1.0 seconds, 2053 bytes.
Oct 26 23:32:11 server spamd[19121]: spamd: result: Y 17 - DKIM_ADSP_CUSTOM_MED,FREEMAIL_FROM,NML_ADSP_CUSTOM_MED,RAZOR2_CF_RANGE_51_100,RAZOR2_CF_RANGE_E8_51_100,RAZOR2_CHECK,RCVD_IN_BL_SPAMCOP_NET,RCVD_IN_BRBL_LASTEXT,RCVD_IN_MSPIKE_BL,RCVD_IN_MSPIKE_L5,RCVD_IN_PSBL,RCVD_IN_RP_RNBL,RDNS_NONE,SPF_HELO_SOFTFAIL,SPF_SOFTFAIL,T_HTML_ATTACH,T_OBFU_HTML_ATTACH scantime=1.0,size=2053,user=nijboer01,uid=1008,required_score=5.0,rhost=ip6-localhost,raddr=::1,rport=58050,mid=<A6DA0E4F.7EC69D6D@gmail.com>,autolearn=no autolearn_force=no
so it is detected as spam.. yet it is not deleted.

edit: yet another piece of info.. found on this blog (same problem in dutch) http://www.webhostingtalk.nl/directadmin/155780-spamassassin-dropt-mail-niet.html#axzz3HLwfn6Yi
the email is send to an non existing user. so it probably has to do with a catch-all inbox
 
Last edited:
Top