The custombuild command does not work after updating DA version 1.646

ViT

Verified User
Joined
Jun 11, 2021
Messages
7
Hi All,
My server alert License check failure, Reason: license is expired.
I updated my server but after updating the custombuild command did not work.
Custombuild 2.0.0 (rev: 2945)
DA: 1.646
OS: CentOS 7.9
[root@1811 custombuild]# ./build versions
./build: line 1516: [: 1e41a5311372d2ce3a4ec360f7c399e2e39635ab: integer expression expected
./build: line 1521: [: 1e41a5311372d2ce3a4ec360f7c399e2e39635ab: integer expression expected
./build: line 1529: [: 1e41a5311372d2ce3a4ec360f7c399e2e39635ab: integer expression expected
./build: line 1534: [: 1e41a5311372d2ce3a4ec360f7c399e2e39635ab: integer expression expected
Your DirectAdmin version (1e41a5311372d2ce3a4ec360f7c399e2e39635ab) is older than minimal required for this version of CustomBuild (1.63). Please run '/usr/local/directadmin/custombuild/build update_da'
Does anyone help me? Sorry, my english is not good.
 
look like you have other cronjob to manual update Custombuild. trying search any relate cronjob and remove it.

In now days, Custombuild will update with Directadmin binary ( No need to manual update ).


and if you found any relate script, Then just re-update Directadmin.
 
look like you have other cronjob to manual update Custombuild. trying search any relate cronjob and remove it.

In now days, Custombuild will update with Directadmin binary ( No need to manual update ).


and if you found any relate script, Then just re-update Directadmin.
Yes, I manual update Custombuild
wget -O /usr/local/directadmin/custombuild/build http://files1.directadmin.com/services/custombuild/2.0/custombuild/build
I trying re-update DirectAdmin but nothing changes
[root@1811 custombuild]# ./build update_da
Updating DirectAdmin

1674901742899.png
1674901831794.png
 
That update command is not valid anymore. What you are doing now is downgrading CB to a very old version. CB is now bundled with DA. You have the latest version of DA installed and with this also the latest version of CB.

I think (not sure) that you need to reinstall DA;


So that you also have the latest version of CB.
 
That update command is not valid anymore.
Really? Since when? I recently updated DA with just the ./build update command.
Afterwards normall I do a ./build update_versions for the rest of the applications to be updated.

As far as explained by @fln the ./build update command would keep working for users who wanted to keep updating via SSH.

I see an error about options.php line 33, couldn't that be the issue? Maybe only plugin has issue again.

@ViT Try updating via my command via SSH, probably that will work for you.
 
I meant that first command in post #3 to download the CB script from files1. From what i see the latest version on those servers is 2945 with a creation date from a few months ago

Even the script on files.directadmin (new main mirror) is outdated
 
I don't know, my build is from 25th januari this year. The one from files.directadmin.com seems to be from september last year indeed.
Odd.
 
Back
Top