The following packages have unmet dependencies

m4ri00sh

Verified User
Joined
May 20, 2007
Messages
215
I know this question is not about DA :) but I know ppl are very helpfull here ... so here it goes....
It is kind of pissing me of sometimes ... so probably most of others....

Hopw do you approach this kind of issue:
s1:/# apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.6.ds1-13etch8) but 2.3.6.ds1-13etch5 is installed
E: Unmet dependencies. Try using -f.
 

m4ri00sh

Verified User
Joined
May 20, 2007
Messages
215
but sometimes this might seriously scr**ed up things, isn't it .... hmmm I wonder ...
 

m4ri00sh

Verified User
Joined
May 20, 2007
Messages
215
hmmm and I have great news :)
reboot and that is what datacenter tech tells me ... he sees when he tries to boot it up..
-----------
errors showing
udevd missing.
/dev/sda1 missing.
-----------

server down... :eek: I wonder if anyone has idea how to fix that.

______________
actually let me start new thread in general section.
 
Last edited:

Dravu

Verified User
Joined
Sep 9, 2007
Messages
324
/dev/sda1 is your HD. Might want to get that tech looking at your server again. He's the only one that can help you in this situation.
 

m4ri00sh

Verified User
Joined
May 20, 2007
Messages
215
I wish but first I have to boot it....
in the shell (ash) I have no command like that available.

PS: not sure but at some point yesterday I tried to run: apt-get install dist-upgrade ... I think .... I don't think I unchecked that once it was selected...


lookin at:
root hd(0,0)
kernel /boot/vmlinuz-2.6.18-4-686 root=/dev/sda1 ro
initrd /boot/initrd.img-2.6.18-4-686
savedefault
 
Top