Trouble with directadmin crash. debian and directadmin problem.

enivr0

New member
Joined
Nov 11, 2019
Messages
4
./directadmin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./directadmin)

./directadmin: /lib/libc.so.6: version `GLIBC_2.15' not found (required by ./directadmin)

./directadmin: /lib/libc.so.6: version `GLIBC_2.14' not found (required by ./directadmin)

./directadmin: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /lib/libssl.so.1.0.0)

./directadmin: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /lib/libcrypto.so.1.0.0)


Hi there. It is a debian I got info that come cuz license is on higher debian then I have debian. I cannot connect and fix it alone by any way wroten in internet. I need help write me what You need to help me fix that problem.
How to fix it?
 

wtptrs

Verified User
Joined
Jul 13, 2015
Messages
71
We had a similar issue on an Ubuntu 14.04 (DA license set to Debian 8) server a while back. What fixed it for us was:

Check for presence of GLIBCXX_3.4.20 on your system:

Code:
strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX_3.4.20
If not present, install libstdc++6 package (instructions below are for Ubuntu 14.04):

Code:
apt-get install software-properties-common
add-apt-repository ppa:ubuntu-toolchain-r/test
apt-get install libstdc++6
GLIBCXX_3.4.20 should be present now:

Code:
strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX_3.4.20
GLIBCXX_3.4.20
Try to restart directadmin:

Code:
service directadmin start
For the GLIBC error, check if the latest version of the 'libc6' package is installed.
 
Last edited:

enivr0

New member
Joined
Nov 11, 2019
Messages
4
Reply

I've prepared a simple script to update Directadmin from beta/stable channel per your needs:

1. Install it:

Code:
cd /root/
wget https://raw.githubusercontent.com/poralix/directadmin-utils/master/core/updateda.sh
chmod 755 updateda.sh
2a. Run to install pre-release version:

Code:
./updateda.sh beta
2b. Run to install stable version:

Code:
./updateda.sh stable
The script will try and auto-detect UID and LID. If it fails then you will need to run the script with options --lid=1234 and --uid=567:

Code:
./updateda.sh beta --lid=1234 --uid=567

or


Code:
./updateda.sh stable --lid=1234 --uid=567
where you will need to use


  • a real License ID instead of 1234
  • a real Client ID instead of 567

You can find them on a page "Licensing / Updates" in Directadmin at admin level.

wget https://raw.githubusercontent.com/poralix/directadmin-utils/master/core/update.sh
--2019-11-12 23:20:52-- https://raw.githubusercontent.com/poralix/directadmin-utils/master/core/update.sh
Resolving raw.githubusercontent.com... 151.101.112.133
Connecting to raw.githubusercontent.com|151.101.112.133|:443... connected.
ERROR: certificate common name `www.github.com' doesn't match requested host name `raw.githubusercontent.com'
.
To connect to raw.githubusercontent.com insecurely, use `--no-check-certificate'.


uname -r
2.6.32-042stab128.2

./directadmin b2000
./directadmin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./directadmin)
./directadmin: /lib/libc.so.6: version `GLIBC_2.15' not found (required by ./directadmin)
./directadmin: /lib/libc.so.6: version `GLIBC_2.14' not found (required by ./directadmin)
./directadmin: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /lib/libssl.so.1.0.0)
./directadmin: /lib/libc.so.6: version `GLIBC_2.14' not found (required by /lib/libcrypto.so.1.0.0)



debian-7.0-x86_64-DA-v3

after
cd /etc/
nano issue
Debian GNU/Linux 6.0



After writing that commands it dont want to work even as root. Please write me more information that You need. I am sure our cooperation will make a fix problem. By the way. I did send a email on directadmin emails, but no body did respond and no body did read a e-mail. Thank You for respondi
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,900
Location
GMT +7.00
As for the issue you face, your OS is too old and needs to be upgraded. Directadmin does not support Debian 6, 7. See https://help.directadmin.com/item.php?id=497

I'm afraid, DirectAdmin servers might even miss binaries for Debian 6 and 7. So you really need to upgrade the server or order a new one and migrate users.
 

enivr0

New member
Joined
Nov 11, 2019
Messages
4
As for the issue you face, your OS is too old and needs to be upgraded. Directadmin does not support Debian 6, 7. See https://help.directadmin.com/item.php?id=497

I'm afraid, DirectAdmin servers might even miss binaries for Debian 6 and 7. So you really need to upgrade the server or order a new one and migrate users.
Hi there it is again me. So after all if directadmin goes to Debian 8.0 64bit only way is start from new. Cuz GNU/Linux and apt-get get bugged and directadmin source back to previouse state is almost impossible to back after big change in server, after it get Debian 8.0 64bit it did lock on Debian 6.0 GNU/Linux and after use all datas, direct admin was have problem .PID. After try directadmin on root setup it stucked and make non able to do update, cuz in that kernel it will allways stuck. Right :)?
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,900
Location
GMT +7.00
Sorry, I don't quite understand what you wrote. And what kernel you mean?

If you can not upgrade your Debian version because of an old kernel installed on the server and it can not be changed due to a technical limitations, then it might be an issue. For example if you use virtualization which does not allow to change a kernel version.

Anyway, Debian 6 and 7 are no longer supported by DirectAdmin. And you will need to get a server with Debian 8+ or CentOS 7+.
 
Top