Troubleshooting - Amazon SES to handle server mail

Hogarth

New member
Joined
Apr 29, 2020
Messages
2
Hi there,

I'm having some issues getting SES to work properly on my DirectAdmin server. Simply want all server mail to be handed by SES.

I followed DA's help page setting up exim.routers/transports etc, as well as another guide I found on a blog (just shows you how to edit the exim.authenticators and routers files)

I've configured with the correct Amazon SES settings:

exim.routers.pre.conf
exim.transports.pre.conf
exim.authenticators.post.conf

I sent a test mail from console and checked exim logs and initially I had a typo in authenticators which generated an error. I corrected this an ran the test again and the report (from what I understand) said it was sent, but nothing arrived in my inbox.

I'm used to getting daily reports from CFD/LFD and none of those are arriving so as I was trying to solve this I set an alias up to forward root mail to my email as an extra test to see if those would come through - None of those are coming through to my inbox either.

Exim log for the last CSF/LFD entry shows the following which doesn't seem out of order either:

2020-04-29 15:40:41 1jTntB-0000PX-13 <= root@the.XXX.org U=root P=local S=3437 T="lfd on the.XXX.org: 213.***.**.*** (NL/Netherlands/......) blocked for port scanning" from <root@the.XXX.org> for root

2020-04-29 15:40:41 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1jTntB-0000PX-13

2020-04-29 15:40:41 1jTntB-0000PX-13 => server <root@the.XXX.org> F=<root@the.XXX.org> R=virtual_user T=dovecot_lmtp_udp S=3580 C="250 2.0.0 <server@XXX.org> 5p+7BOmRqV5ndgAA0LLvCg Saved"

2020-04-29 15:40:41 1jTntB-0000PX-13 Completed
The domain is set up correctly on SES (I've been using the domain for other mailing stuff which comes through fine) so sending and receiving through this Amazon SES email works for other stuff.

I was wondering if someone could help me out with this? Anything I can try to make it work? Anything else I can look at that could be preventing messages leaving the server?

Many thanks.
 

bdacus01

Verified User
Joined
Jul 22, 2017
Messages
1,036
Location
Murfreesboro

Hogarth

New member
Joined
Apr 29, 2020
Messages
2
Thanks for the response. Already did that prior to posting - The first link being the article I followed at the start (it contains a couple of mistakes).

I've since resolved the issue.
 
Top