unable to connect

iphoneil

Verified User
Joined
Mar 23, 2014
Messages
29
I installed the system about a month and a half ago, everything worked fine, I added sites and everything is excellent.

I'm trying to connect now to the system I can not, access through ssh is active but the interface does not open. I also did a server restart, but it did not help.

Can anyone help?
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
What error notice occurs? Because normally when you try to access ssh via an ssh client, it will give an error notice or timeout error or just a failed to connect.
Which one do you see?

Are you running Centos? In that case you should be able to login to ssh directly as root.
If you are loggin in as another user, login to DA en use the file editor in the admin section to check /etc/ssh/sshd_config at the bottom which users are stated there as allowed users.

Also check your firewall that port 22 (or whatever port you are using for ssh) is open for incoming and outgoing traffic.
 

iphoneil

Verified User
Joined
Mar 23, 2014
Messages
29
What error notice occurs? Because normally when you try to access ssh via an ssh client, it will give an error notice or timeout error or just a failed to connect.
Which one do you see?

Are you running Centos? In that case you should be able to login to ssh directly as root.
If you are loggin in as another user, login to DA en use the file editor in the admin section to check /etc/ssh/sshd_config at the bottom which users are stated there as allowed users.

Also check your firewall that port 22 (or whatever port you are using for ssh) is open for incoming and outgoing traffic.
thank you for the answer.

Apparently you did not understand me, I am trying to access the system through (ui) management of diractadmin, rather than via ssh. Through ssh there is no problem at all.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
You're welcome.

It seems I got the wrong impression because you wrote:
I'm trying to connect now to the system I can not, access through ssh is active but the interface does not open
and SSH has nothing to do with the Directadmin User interface. Or am I misunderstanding again?
Are you trying and not succeeding to enter the DA management interface like http://yourdomain.com:2222 or can you login to DA but can't access something in your system from the interface?

If it's DA via port 2222, check the da logs or see what's happening when starting DA in debug mode:
https://help.directadmin.com/item.php?id=293

If you are trying to use a shell from the DA user interface, I don't even have that here. Maybe a screenshot would be a bit of help with understanding the problem.
 

iphoneil

Verified User
Joined
Mar 23, 2014
Messages
29
and SSH has nothing to do with the Directadmin User interface.
Yes, everything is ok in terms of ssh access.

Are you trying and not succeeding to enter the DA management interface like http://yourdomain.com:2222
Yes, that's the problem. I can not sign in via url to interface.

If it's DA via port 2222, check the da logs or see what's happening when starting DA in debug mode:
https://help.directadmin.com/item.php?id=293
I did what you said (picture attached). I am trying to access through the url and I do not get any data through the debug

Screen Shot 2019-06-10 at 07.27.40.png
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
Seems you changed the DA port for some reason. It's listening at 7732 but seems to run correctly.

Looks indeed like everything is running correctly.
1.) Did you check the logfiles in /var/log/directadmin if something can be found there?
2.) Did you open 7732 both incoming and outgoing in your firewall?
 

iphoneil

Verified User
Joined
Mar 23, 2014
Messages
29
Seems you changed the DA port for some reason. It's listening at 7732 but seems to run correctly.

Looks indeed like everything is running correctly.
1.) Did you check the logfiles in /var/log/directadmin if something can be found there?
2.) Did you open 7732 both incoming and outgoing in your firewall?
2. root@abeksis:/var/log/directadmin# iptables -I INPUT -p tcp -m tcp --dport 7732 -j ACCEPT

It works :). Thank you for the wonderful support.
 
Last edited:
Top