Update APC to 3.1.4

canreo

Verified User
Joined
Mar 5, 2007
Messages
28
I have APC 3.0.19 installed on my server, but I would like to upgrade to 3.1.4.

I have tried "pecl install apc" and "pecl upgrade apc" I get this message "pecl/apc is already installed and is the same as the released version 3.0.19 install failed"

How do I tell PECL to grab the newest pear package and install it?
 
Last edited:

DoYouSpeakWak

New member
Joined
Nov 2, 2010
Messages
4
Install manually

I did this just a few weeks back. No problem. Just do it manually.

wget the file. configure, make, make install etc. google "apc+make install" that should give you a few how to guides.
 

Petertjuh360

Verified User
Joined
Nov 7, 2010
Messages
350
Sorry for bumping.

I have version 3.1.9 and want to update to version 3.1.12.
Badly enough pecl doesn't see the newer version and adding -f to the command doesn't work.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,932
Location
GMT +7.00
You can always download the sources file and build apc from it:

Code:
cd /usr/local/src
wget http://pecl.php.net/get/APC-3.1.12.tgz
tar -zxvf APC-3.1.12.tgz
cd APC-3.1.12
phpize
./configure
make && make install
That's it.
 

Petertjuh360

Verified User
Joined
Nov 7, 2010
Messages
350
You can always download the sources file and build apc from it:

Code:
cd /usr/local/src
wget http://pecl.php.net/get/APC-3.1.12.tgz
tar -zxvf APC-3.1.12.tgz
cd APC-3.1.12
phpize
./configure
make && make install
That's it.
It works, thank you!
 

Wanabo

Verified User
Joined
Jan 19, 2013
Messages
170
Thanks zEitEr, your solution worked for me. I was running an old version which caused segmentation faults. Updated to the latest beta, server is running for several hours now without segmentation faults. :D

When I want to install a new version. Do I need to remove the previous version? If so how do I do that?
Or can I use the procedure again described by zEitEr?
 
Top