update from CB 1.2 to 2.0 on Centos 5.11 32bit

Tootle

Verified User
Joined
Sep 1, 2011
Messages
38
I want to start using nginx reverse proxy, but it's said that custombuild 2.0 is required, ( http://forum.directadmin.com/showthread.php?t=49438 ) and I'm currenty running CB1.2 with DA 1.50.1 what is more problem, my VPS provider said that he strongly reccomends Centos 6 where it is better suited for CB 2.0 ...

- so my question is: is it safe to migrate to CB2.0 on CentOS 5.11 using this how-to (https://help.directadmin.com/item.php?id=555) where I'm using PHP CLI + mod_ruid2

Code:
Apache 2.2.31	
DirectAdmin 1.50.1	
Exim 4.87	
MySQL 5.0.67	
Named 9.3.6	
ProFTPd 1.3.5b	
Php 5.3.29
or in this matter OS version is irrevelant?
 

Tootle

Verified User
Joined
Sep 1, 2011
Messages
38
Thanks, @smtalk - I'm aware my question looks rather silly, but I want to read some thoughts about that, as I've nowhere seen any warnings on the topic and I'm doing in for the first time. One question more: is there any failover on this update process, i.e. revert back to CB 1.2 if sth will go wrong or DA System Backup will do - as I will be doing this on a production srv.
 

Tootle

Verified User
Joined
Sep 1, 2011
Messages
38
According to this https://help.directadmin.com/item.php?id=354 i have to take this step before migration to CB 2.0 but is i.e. cronie for Centos 6 specific?


Code:
$ yum install wget gcc gcc-c++ flex bison make bind bind-libs bind-utils openssl openssl-devel perl quota libaio libcom_err-devel libcurl-devel gd zlib-devel zip unzip libcap-devel cronie bzip2 cyrus-sasl-devel perl-ExtUtils-Embed autoconf automake libtool which patch mailx bzip2-devel lsof db4-devel
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: centos.hitme.net.pl
 * epel: ftp.icm.edu.pl
 * extras: centos.hitme.net.pl
 * rpmforge: mirror1.hs-esslingen.de
 * updates: centos.hitme.net.pl
Excluding Packages in global exclude list
Finished
4280 packages excluded due to repository priority protections
Setting up Install Process
Package wget-1.11.4-3.el5_8.2.i386 already installed and latest version
Package gcc-4.1.2-55.el5.i386 already installed and latest version
Package gcc-c++-4.1.2-55.el5.i386 already installed and latest version
Package flex-2.5.4a-41.fc6.i386 already installed and latest version
Package bison-2.3-2.1.i386 already installed and latest version
Package 1:make-3.81-3.el5.i386 already installed and latest version
Package 30:bind-9.3.6-25.P1.el5_11.8.i386 already installed and latest version
Package 30:bind-libs-9.3.6-25.P1.el5_11.8.i386 already installed and latest version
Package 30:bind-utils-9.3.6-25.P1.el5_11.8.i386 already installed and latest version
Package openssl-0.9.8e-40.el5_11.i686 already installed and latest version
Package openssl-devel-0.9.8e-40.el5_11.i386 already installed and latest version
Package 4:perl-5.8.8-43.el5_11.i386 already installed and latest version
Package 1:quota-3.13-8.el5.i386 already installed and latest version
Package libaio-0.3.106-5.i386 already installed and latest version
No package libcom_err-devel available.
No package libcurl-devel available.
Package gd-2.0.33-9.4.el5_4.2.i386 already installed and latest version
Package zlib-devel-1.2.3-7.el5.i386 already installed and latest version
Package zip-2.31-2.el5.i386 already installed and latest version
Package unzip-5.52-3.el5.i386 already installed and latest version
Package libcap-devel-1.10-26.i386 already installed and latest version
No package cronie available.
Package bzip2-1.0.3-6.el5_5.i386 already installed and latest version
Package cyrus-sasl-devel-2.1.22-7.el5_8.1.i386 already installed and latest version
No package perl-ExtUtils-Embed available.
Package autoconf-2.59-12.noarch already installed and latest version
Package automake-1.9.6-3.el5.noarch already installed and latest version
Package libtool-1.5.22-7.el5_4.i386 already installed and latest version
Package which-2.16-7.i386 already installed and latest version
Package patch-2.5.4-31.el5.i386 already installed and latest version
Package mailx-8.1.1-44.2.2.i386 already installed and latest version
Package bzip2-devel-1.0.3-6.el5_5.i386 already installed and latest version
Package lsof-4.78-6.i386 already installed and latest version
Package db4-devel-4.3.29-10.el5_5.2.i386 already installed and latest version
Nothing to do
Is it safe to proceed ->CB 2.0 migration without libcom_err-devel,libcurl-devel,perl-ExtUtils-Embed?
 
Top