Update pre-install commands for PHP 7.4

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,243
Location
GMT +7.00
Hello,

At minimum PHP 7.4 on CentOS 8 requires the following packages: oniguruma-devel and oniguruma
Please update a list of pre-install packages with them.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,891
Location
LT, EU
Hello,

At minimum PHP 7.4 on CentOS 8 requires the following packages: oniguruma-devel and oniguruma
Please update a list of pre-install packages with them.
CustomBuild installs the package automatically, since PHP 7.4 support was added.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,243
Location
GMT +7.00
A fresh installation on CloudLinux/CentOS 8 failed this morning because of missing packages. Had to install them manually and then start an installation of DirectAdmin once again.

So there might be something wrong.
 

xerox

Verified User
Joined
Jul 16, 2019
Messages
93
Using newest pre release binaries, installing new php 7.4 caused error:
  • No package 'oniguruma' found
Please fix this. Thanks.
 
Top