Upgarde to custombuild 2.0 -> apache error

indexs

Verified User
Joined
Jun 11, 2010
Messages
77
Hi, everyone.

Wanted to upgrade my custom build, but got stuck at the beginning.

Started here -> http://forum.directadmin.com/showthread.php?t=44743

And stopped after command:

Code:
./build apache
And got this error:

Code:
You cannot install Apache, because you do not have it set in options.conf file.
This is mine options.conf

Code:
#PHP settings.
#Default version of PHP is always php1_release. Possible values for php1/php2_release: 5.3, 5.4, 5.5, no. php1/php2_mode: mod_php, fastcgi, php-fpm or suphp)
php1_release=5.3
php2_release=no
php1_mode=mod_php
php2_mode=php-fpm
htscanner=yes
php_ini=no
php_timezone=EET
#Possible values - production or development
php_ini_type=production
ioncube=no
x-mail-header=yes
zend=no

#HTTP server. Possible values: apache, nginx, nginx_apache
webserver=apache

#Apache settings
#Possible value: 2.4
apache_ver=2.4
mod_ruid2=yes
secure_htaccess=no
harden-symlinks-patch=yes
use_hostname_for_alias=auto
redirect_host=server.domain.com
redirect_host_https=no

#Possible values - 5.1, 5.5, 5.6
mysql=5.6
mysql_inst=no
mysql_backup=yes
mysql_backup_dir=/usr/local/directadmin/custombuild/mysql_backups

#Web applications
phpmyadmin=yes
phpmyadmin_ver=4
squirrelmail=yes
roundcube=yes

#Mail options
exim=no
eximconf=no
clamav=no
spamassassin=no
dovecot=yes
pigeonhole=no

#Statistics
awstats=no
webalizer=yes

#FTP options - possible values: proftpd, pureftpd
ftpd=pureftpd

#Jailed shell
jail=no

#Autoconf/automake/libtool options
autoconf=yes
automake=yes
libtool=yes
curl=yes

#versions of zlib, apr_util and libxml2 (experts only)
zlib=no
new_zlib=no
new_xml2=yes
new_pcre=no
new_suphp=no
old_apr_util=no

#Custombuild options
custombuild=2.0
autover=no
bold=yes
clean=yes
cleanapache=no
clean_old_tarballs=yes
clean_old_webapps=yes
downloadserver=files6.directadmin.com

#Cron settings
cron=no
cron_frequency=daily
email=email@domain.com
notifications=yes
da_autoupdate=no
updates=no
webapps_updates=yes

#Cloudlinux settings
cloudlinux=no
cagefs=no
Any suggestions please?

p.s. maybe I`m blind, but did not find any answer on google and forum... :(
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,541
I can't see anything wrong with your apache settings in options.conf, so that is strange. Try to run ./build update a extra time, and see if it helps?

Also I notice some settings in your options.conf you might like to change, you have these:

Code:
php_ini=no
mysql_inst=no
exim=no
eximconf=no
Most likely you want to change all those to yes, and then run ./build update - maybe you should send a pm to smtalk about this apache problem?
 

indexs

Verified User
Joined
Jun 11, 2010
Messages
77
Hi, Thank you for you answer, but still the same, can`t understand what`s wrong...

I had made this update on previous server and everything was ok, but now this...
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,541
It sounds like a bug in custombuild to me. Maybe try to re-add webserver and apache server settings using command line, and if you are lucky it will fix the problem:

Code:
./build set webserver apache
./build set apache_ver 2.4
./build update
./build apache
If it does not help, then do you have any errors when doing ./build versions and ./build options commands? Also does ./build versions show any apache version?

Edit: Can a moderator please move this thread to "Custombuild 2.0" forum at http://forum.directadmin.com/forumdisplay.php?f=81 , then maybe smtalk and others might notice the thread. :)
 
Last edited:

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,164
Location
GMT +7.00
The thread is now moved to "CustomBuild 2.0" subforum, so it could be easily found and the bug would be fixed soon.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,792
Location
LT, EU
Hello,

The bug is already fixed and it will be uploaded to files1 downloadserver soon. To fix it manually, just open the build file, find:
Code:
if [ "${WEBSERVER_OPT}" != "apache" ] || [ "${WEBSERVER_OPT}" != "nginx_apache" ]; then
And replace with:
Code:
if [ "${WEBSERVER_OPT}" != "apache" ] && [ "${WEBSERVER_OPT}" != "nginx_apache" ]; then
That's it. Good luck and thank you for the report :)
 

indexs

Verified User
Joined
Jun 11, 2010
Messages
77
Thank you,

But now having problems with mod_ruid2 httpd wont start :(

Code:
Starting httpd: httpd: Syntax error on line 17 of /etc/httpd/conf/httpd.conf: Syntax error on line 2 of /etc/httpd/conf/extra/httpd-phpmodules.conf: Cannot load /usr/lib/apache/mod_ruid2.so into server: /usr/lib/apache/mod_ruid2.so: undefined symbol: unixd_config
 

indexs

Verified User
Joined
Jun 11, 2010
Messages
77
Thank you for your help!

Just finished rebuild everything and it looks like it works! :D

Thank you once again :)
 
Top