urgent help need multiple ip's

chow

Verified User
Joined
Aug 27, 2003
Messages
125
Location
The Netherlands
Hi,

I installed RH9 with 2 nics (1 ipaddress on each nic). After that DA installed the controlpanel for me 2 days ago. When I logged on only one ip was visible through the controlpanel. I added a couple of ipaddresses to eth0 and decided if eth1 is not visible in DA i could just disable it and use the ipaddress on eth0. I therefore changed the /etc/sysconfig/ifcfg-eth1 in on boot=no
After rebooting the server I now lost the ipadress on which the controlpanel listens. Weird because this ipaddres is on eth0 and not on eth1. I however thought well let's just edit the ifcfg-eth1 again to on boot=yes to get the original situation back. No success however. I cannot access the controlpanel anymore and don't know how to recover this situation. Could anyone pls help me out with this bizarre thing??

Regards
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

I'm not sure how to sort out your network adaptor issues, but if you need DA to look on a different device for the license IP, just edit:

/usr/local/directadmin/conf/directadmin.conf

and edit (or add):

ethernet_dev=eth1

(where eth1, or eth0 etc.. is the device with your license IP).
Failing that, you can always contact support@directadmin.com and we can change the IP in your license file.

John
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

If no device is in the directadmin.conf, it will default to eth0 (this is the default)

John
 
Top