Urgent - SMTP is acting as open relay

locateMe

Verified User
Joined
Feb 12, 2004
Messages
44
My SMTP server is acting as an Open Relay is as much as anyone can use it as an smtp server without presenting a valid email address or using SMTP authentication.

I see in the help pages that SMTP authentication is meant to be used but I can't see where to switch it on and I am able to send messages through it with it switched off and with a false email address.

Can someone advise urgently as there is enough spam in the world without me adding to it ;)

Thanks

Steve
 

ProWebUK

Verified User
Joined
Jun 9, 2003
Messages
2,326
Location
UK
Do you have the option:

allow_domain_literals

Set as true?

Also check the other relaying options in the exim conf for anything unusual..

Chris
 

locateMe

Verified User
Joined
Feb 12, 2004
Messages
44
Where is that?

I have SSH access as ROOT and DA access as Admin - where would I find that variable?

PS I didn't set the server up - someone else did.
 

locateMe

Verified User
Joined
Feb 12, 2004
Messages
44
it's false

allow_domain_literals = false

but also

hostlist auth_relay_hosts = *

if that means anything

Thanks

Steve
 

locateMe

Verified User
Joined
Feb 12, 2004
Messages
44
Solved!

Panic over - it wasn't open relay after all.

I tracked the problem down to another undocumented feature of DA - popbeforesmtp - as I had checked pop within the last 30mins it allowed my IP to send - grrrr

This really should be a configurable feature from inside DA - you can't expect novice users to have to start editing in at the root level for something as straightforward as how the SMTP server reacts.

Thanks to Chris for his asssistance.

Regards

Steve
 
Top