Using CB2.0 I still have Apache 2.2 conf files?

darkus

Verified User
Joined
Dec 15, 2005
Messages
114
Ive installed CB2.0 and using it i've successfully installed php 5.4 and apache 2.4

However in the control panel when I load up httpd.conf the header says:

#
# This is the main Apache HTTP server configuration file. It contains the
# configuration directives that give the server its instructions.
# See <URL:http://httpd.apache.org/docs/2.2> for detailed information.
# In particular, see
# <URL:http://httpd.apache.org/docs/2.2/mod/directives.html>
# for a discussion of each configuration directive.
#
# Do NOT simply read the instructions in here without understanding
# what they do. They're here only as hints or reminders. If you are unsure
# consult the online docs. You have been warned.
It seems I may still have the 2.2 options file? Im not sure if there is actually any difference, but just wanted to be sure.

I did run
PHP:
./build rewrite_confs
but the file does not change

Thanks!
 

darkus

Verified User
Joined
Dec 15, 2005
Messages
114
check the value in options.conf
then download the new package by
./build update
./build apache
Yup did all that and Apache 2.4 is actually running on the system just fine. Its just that the .conf files seem to be the old 2.2 version ones.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,478
Location
LT, EU
Hello,

Are you sure it's CustomBuild 2.0? Please run "./build | grep Version".

Thank you!
 

darkus

Verified User
Joined
Dec 15, 2005
Messages
114
Hello,

Are you sure it's CustomBuild 2.0? Please run "./build | grep Version".

Thank you!
You are correct, it seems to be version 1.2!
PHP:
|                   Version: 1.2.34                      |
Which is strange because I did exactly what you said to upgrade to CB2.0 int he FAQ:

cd /usr/local/directadmin
mv custombuild custombuild_1.x
wget http://files.directadmin.com/services/custombuild/2.0/custombuild.tar.gz
tar xvzf custombuild.tar.gz
cd custombuild
./build
I will try again!
 

darkus

Verified User
Joined
Dec 15, 2005
Messages
114
I figured out what happened! Maybee a note to the novices out there like me. The directory already contains a custombuild.tar.gz so that when you do the wget it will download it as custombuild.tar.gz.1 and when the next tar command is run its just untarring the old 1.2 CB....!! so stupid of me

and ./build rewrite_confs successfully changes the .conf files! Great day!
 
Last edited:
Top