weird - domain/email issue (email at gmail)

rnbwkat

Verified User
Joined
May 3, 2016
Messages
22
Ok, here is a strange problem I am banging my head against a wall. I have 3 systems, all with DA. One of the systems is running a domain for a client but DNS is on the registrar's system. Email is also hosted at gmail. So basically the DNS entry points to my server, and the MX records point to gmail.

On the webserver, we have a "contact" form, and it does not matter if we use the form, or just the mail command. But if I try to email the "domain" in question -- "mail -r me@gmail.com user1@hosteddomain.com" and hosteddomain.com is the domain name running on my server, the mail bounces with undeliverable. The Exim logs don't show much of anything.

Dig with MX shows the correct mail records as does a dig with the hosted domain. If I login to either of my other 2 hosts, identically configured, and email user1@hosteddomain.com, it works perfectly. So it seems that the only host with problems is the one hosting the webserver and the domain. I can't figure out why it thinks the mail should be going to localhost if the MX records resolve correctly? Is there something in DA that I can set to force it to disable email for this domain?

So confused...
Kat
 

rnbwkat

Verified User
Joined
May 3, 2016
Messages
22
Never mind - I figured it out digging through all the screwy docs.
Just remove the domain name from /etc/virtual/domains file and restart exim and dovecot.
It sure would be nice if documentation was a bit better organized. A heading like "Domains with External Email"

thanks
K
 

ditto

Verified User
Joined
Apr 27, 2009
Messages
2,580
There is no need to manually remove anything from /etc/virtual/domains, and no need to restart exim and dovecot. All you need to do is to go to user level and click on "MX Records", at that page you remove the tick at the check-box for "Local Mail Server" and click "Save".
 
Top