Welcome emails rejected due non-fully qualified address

mingmeng

Verified User
Joined
Apr 11, 2017
Messages
8
I am looking for some help - relative newbie!

What I see now is:

504 5.5.2 <diradmin@server1>: Sender address rejected:
need fully-qualified address

What I used to see was:

from diradmin by server1.mingmengtou.net with local (Exim 4.87)
(envelope-from <diradmin@server1.mingmengtou.net>)

So something has changed or I've inadvertently changed something.

I'm posting a thread because I after quite a bit of drifting around forum - I have not yet found a definitive answer.

I am now on Exim 4.92 and I've run the set_permissions script and both after a build update.

DNS is on my VPS providers servers - on looking at dns entries in the DA CP I note that local is no in red whereas every thing else is yes in green. Server IP changed recently - as far as I know all DNS entries updated but also I did a build update, etc after that and i can see a DA updated on July 13 which is when I think that the issue started. I believe this was an issue some years ago but I could not discern a clear answer for what to do.

I appreciate any help or pointers to the answer that I've yet to stumble across.

Thank you

Neil
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,218
Location
Maastricht
You shoud set your admin email address if you have not done so yet.

Login to DirectAdmin, click the "List Administrators" link, dan click your admin name.
When selecting Admin's User Data you can scroll-down until you see the current admin email and change it to your liking.

After that that, try rebuilding the newest Exim, and the newest exim spamblocker configuration (eximconf), which you can get by changing the options and build it again:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build set exim yes
./build set eximconf yes
./build set eximconf_release 4.5
./build update
./build exim
./build eximconf
This should also give you the newest exim.pl file.

Normally after this, the mail would be send from diradmin@server1.mingmengtou.net again if everything is correct.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
13,854
Location
GMT +7.00
Hello Neil,

Beside
Richard has already suggested, there are still more things to be checked.

1. Hostname usually resets on a reboot on certain VMs/VPS to the one set in a control panel where you purchase a server. So you will need to connect to a dashboard provided by your server company and make sure you've got a correct hostname there. Something like server name, etc.

2. In a server console over SSH check /etc/hosts, in a line with your IP you should see a correct hostname.

3. In DirectAdmin Web-UI as admin check administrator settings and make sure hostname is correct.
 

mingmeng

Verified User
Joined
Apr 11, 2017
Messages
8
Richard and Alex,

Thank you both for your replies.

Richard I tried your suggestion first - emails now received by external addresses - such as mine at startmail.com the header now looks:

Return-Path: <SRS0=Pm4xsf=VQ=server1=diradmin@mingmengtou.net>
X-Spam-Status: No, score=0.0 required=5.0 tests=KHOP_DYNAMIC,NORMAL_HTTP_TO_IP,
T_FILL_THIS_FORM_SHORT,WEIRD_PORT
X-Spam-Level:
X-Spam-Checker-Version: SpamAssassin
Delivered-To: neilctimms@startmail.com
Received: from mx1.be1.ams1.startmail.org (mx1.app.be1.ams1.startmail.org [10.199.13.135])
by vlt03.be1.ams1.startmail.org (Postfix) with ESMTPS id 8A806138822
for <neilctimms@startmail.com>; Fri, 19 Jul 2019 17:37:52 +0000 (UTC)
Received: from mx2.fe1.ams1.startmail.org (rt215bb131-145-190.routit.net [145.131.215.190])
by mx1.be1.ams1.startmail.org (Postfix) with ESMTPS id 8347618006F
for <neilctimms@startmail.com>; Fri, 19 Jul 2019 17:37:52 +0000 (UTC)
Received-SPF: Pass (sender SPF authorized) identity=mailfrom; client-ip=213.108.198.176; helo=server1; envelope-from=srs0=pm4xsf=vq=server1=diradmin@mingmengtou.net; receiver=mingmengtou@use.startmail.com
Authentication-Results: mx2.fe1.ams1.startmail.org; dkim=none;
dkim-atps=neutral
Received: from server1 (unknown [213.108.198.176])
(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
(No client certificate requested)
by mx2.fe1.ams1.startmail.org (Postfix) with ESMTPS id 5C3D8C0057
for <mingmengtou@use.startmail.com>; Fri, 19 Jul 2019 17:37:52 +0000
(UTC)
Received: from diradmin by server1 with local (Exim 4.92)
(envelope-from <diradmin@server1>)
id 1hoWpM-0001uw-1g
for contact@mingmengtou.net; Fri, 19 Jul 2019 13:37:52 -0400
To: contact@mingmengtou.net
From: mingmeng.mingmengtou.net <contact@mingmengtou.net>
Sender: mingmeng.mingmengtou.net <contact@mingmengtou.net>
Reply-To: mingmeng.mingmengtou.net <contact@mingmengtou.net>
X-DirectAdmin-Sender: mingmeng
Subject: Your account for neilt.org is now ready for use.
Message-Id: <E1hoWpM-0001uw-1g@server1>
Date: Fri, 19 Jul 2019 13:37:52 -0400
X-Authenticated-Id: diradmin
X-StartMail-Is-Local-Vault-Mail: True

Alex, I also worked through your steps: details in the VPS control panel were correct, and the DA settings seemed good. I did however make a DNS entry for server1.mingmengtou.net in the VPS CP DNS - but the first actions had worked - not sure if I should have done DNS for server1.mingmengtou.net earlier or not? I had of course an existing DNS entry for mingmengtou.net already.

server1.mingmengtou.net 5/9999 ns1.vpsget.com ns2.vpsget.com
NS Records
server1.mingmengtou.net ns1.vpsget.com 600
server1.mingmengtou.net ns2.vpsget.com 600
A Records
server1.mingmengtou.net 213.108.198.176 600
AAAA Records
Domain IP Address TTL
MX Records
server1.mingmengtou.net 10 mail.mingmengtou.net 600
TXT Records
server1.mingmengtou.net "v=spf1 a mx ip4:213.108.198.176 ~all" 600

root@server1:/usr/local/directadmin/custombuild# cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

127.0.0.1 localhost.localdomain localhost
# Auto-generated hostname. Please do not remove this comment.
2a02:748:d000:8::1:1454 server1.mingmengtou.net server1
::1 localhost ip6-localhost ip6-loopback

Thank you both for your help - emails now escaping the server so a good result - I will still accept any advice for any other steps you think are needed to ensure everything stays that way.

Thank you

Neil
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,218
Location
Maastricht
As for the help, you're welcome.

However, you still might check the things that zEitEr said, because I see this:
helo=server1;
This should be a FQDN which it isn't now. It will deliver mail to some servers, but you could get into trouble with some others especially with Microsoft servers (hotmail/outlook/live) and Gmail.

However I don't know exactly where or why this is only "server1" instead of the full hostname again.
 
Top