wget error

wm20472

Verified User
Joined
Mar 21, 2006
Messages
110

I rebuild wget "make" show error as following, how can I do?

[root@fs01 wget-1.8.2]# make
cd src && make CC='gcc' CPPFLAGS='' DEFS='-DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/usr/etc/wgetrc\" -DLOCALEDIR=\"/usr/share/locale\"' CFLAGS='-O2 -Wall -Wno-implicit' LDFLAGS='' LIBS='-lssl -lcrypto -ldl ' prefix='/usr' exec_prefix='/usr' bindir='/usr/bin' infodir='/usr/info' mandir='/usr/man' manext='1'
make[1]: Entering directory `/usr/local/directadmin/wget-1.8.2/src'
gcc -I. -I. -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/usr/etc/wgetrc\" -DLOCALEDIR=\"/usr/share/locale\" -O2 -Wall -Wno-implicit -c ftp.c
In file included from /usr/include/openssl/kssl.h:71,
from /usr/include/openssl/ssl.h:165,
from rbuf.h:34,
from ftp.c:50:
/usr/include/ctype.h:102: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:103: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:104: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:105: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:106: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:107: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:108: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:109: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:110: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:111: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
/usr/include/ctype.h:112: error:expected 「=」, 「,」, 「;」, 「asm」 or 「__attribute__」 before 「use」
make[1]: *** [ftp.o] Error 1
make[1]: Leaving directory `/usr/local/directadmin/wget-1.8.2/src'
make: *** [src] Error 2
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,331
Location
LT, EU
Is it happening on FreeBSD? You may install wget this way:
Code:
pkg install wget
Otherwise you may try gmake instead of make on FreeBSD.
 
Top