I think it would make sense to name options like that something like "nginx_unit", so that it's clear what it actually is.It's documented:
# ./build opt_help full | grep unit unit: yes, no. Current value: yes. Default value: no. Description: Nginx Unit. Dynamic Application Server. ALPHA support.