Wireguard not working with release of 8.1.1911!!

DomnikBritto

Verified User
Joined
Nov 23, 2019
Messages
8
Not sure if anyone else has run into this, but it appears Wireguard is no longer working with the release of 8.1.1911 and the upgrade to kernel 4.18.0-147.3.1.el8_1.x86_64. This is just an FYI since we probably just need an update to Wireguard, but if you rely on it for your VPN you might want to hold off on updating the system. Booting to the previous kernel also worked in my case, but if anyone has a better solution I'm all ears.

Attempting to run wg-quick gives the following errors:

RTNETLINK answers: Operation not supported
Unable to access interface: Protocol not supported

It appears the kernel module cannot be loaded or built.

$ sudo lsmod | grep wire
$ sudo modprobe wireguard
modprobe: FATAL: Module wireguard not found in directory /lib/modules/4.18.0-147.3.1.el8_1.x86_64
$ dkms status
Error! Could not locate dkms.conf file.
File: /var/lib/dkms/wireguard/0.0.20191206/source/dkms.conf does not exist.
$ sudo dkms build wireguard/0.0.20191206
Error! Could not locate dkms.conf file.
File: /var/lib/dkms/wireguard/0.0.20191206/source/dkms.conf does not exist.
 

DomnikBritto

Verified User
Joined
Nov 23, 2019
Messages
8
Not sure if anyone else has run into this, but it appears Wireguard is no longer working with the release of 8.1.1911 and the upgrade to kernel 4.18.0-147.3.1.el8_1.x86_64. This is just an FYI since we probably just need an update to Wireguard, but if you rely on it for your VPN you might want to hold off on updating the system. Booting to the previous kernel also worked in my case, but if anyone has a better solution I'm all ears.

Attempting to run wg-quick gives the following errors:

RTNETLINK answers: Operation not supported
Unable to access interface: Protocol not supported

It appears the kernel module cannot be loaded or built.
https://myip.kim/ https://birthdaywishes.onl/ https://elecpay.in/tneb/


$ sudo lsmod | grep wire
$ sudo modprobe wireguard
modprobe: FATAL: Module wireguard not found in directory /lib/modules/4.18.0-147.3.1.el8_1.x86_64
$ dkms status
Error! Could not locate dkms.conf file.
File: /var/lib/dkms/wireguard/0.0.20191206/source/dkms.conf does not exist.
$ sudo dkms build wireguard/0.0.20191206
Error! Could not locate dkms.conf file.
File: /var/lib/dkms/wireguard/0.0.20191206/source/dkms.conf does not exist.

issue solved!!
 
Top