yum update error

DhoTjai

Verified User
Joined
Apr 23, 2006
Messages
80
Location
Netherlands
Hi,

I'm getting this with yum update:
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-devel.x86_64 0:2.6.9-55.0.12.EL set to be installed
---> Package xorg-x11-xauth.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package seamonkey-nss.i386 0:1.0.9-6.el4.centos set to be updated
---> Package libpng.i386 2:1.2.7-3.el4_5.1 set to be updated
---> Package cyrus-sasl-sql.i386 0:2.1.19-14 set to be updated
---> Package tzdata.noarch 0:2007h-1.el4 set to be updated
---> Package cyrus-sasl-ntlm.i386 0:2.1.19-14 set to be updated
---> Package qt.x86_64 1:3.3.3-13.RHEL4 set to be updated
---> Package qt.i386 1:3.3.3-13.RHEL4 set to be updated
---> Package cyrus-sasl-md5.i386 0:2.1.19-14 set to be updated
---> Package cyrus-sasl-md5.x86_64 0:2.1.19-14 set to be updated
---> Package kernel-smp.x86_64 0:2.6.9-55.0.12.EL set to be installed
---> Package ruby.x86_64 0:1.8.1-7.EL4.8.1 set to be updated
---> Package seamonkey-nss.x86_64 0:1.0.9-6.el4.centos set to be updated
---> Package kdebase.i386 6:3.3.1-6.el4 set to be updated
---> Package seamonkey-nspr.x86_64 0:1.0.9-6.el4.centos set to be updated
---> Package cups-libs.i386 1:1.1.22-0.rc1.9.20.2.el4_5.2 set to be updated
---> Package cups-libs.x86_64 1:1.1.22-0.rc1.9.20.2.el4_5.2 set to be updated
---> Package ruby-libs.i386 0:1.8.1-7.EL4.8.1 set to be updated
---> Package kdelibs.x86_64 6:3.3.1-9.el4 set to be updated
---> Package cyrus-sasl.i386 0:2.1.19-14 set to be updated
---> Package cups.x86_64 1:1.1.22-0.rc1.9.20.2.el4_5.2 set to be updated
---> Package seamonkey-nspr.i386 0:1.0.9-6.el4.centos set to be updated
---> Package xorg-x11-libs.i386 0:6.8.2-1.EL.31 set to be updated
---> Package xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.31 set to be updated
---> Package flac.i386 0:1.1.0-7.el4_5.2 set to be updated
---> Package kdelibs.i386 6:3.3.1-9.el4 set to be updated
---> Package ruby-devel.x86_64 0:1.8.1-7.EL4.8.1 set to be updated
---> Package xorg-x11-xdm.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package kernel-smp-devel.x86_64 0:2.6.9-55.0.12.EL set to be updated
---> Package cyrus-sasl-plain.x86_64 0:2.1.19-14 set to be updated
---> Package xorg-x11-libs.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package cyrus-sasl-devel.x86_64 0:2.1.19-14 set to be updated
---> Package xorg-x11-xfs.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package xorg-x11-Mesa-libGLU.i386 0:6.8.2-1.EL.31 set to be updated
---> Package cyrus-sasl-plain.i386 0:2.1.19-14 set to be updated
---> Package libvorbis-devel.x86_64 1:1.1.0-2.el4.5 set to be updated
---> Package pcre.i386 0:4.5-4.el4_5.4 set to be updated
---> Package libvorbis.i386 1:1.1.0-2.el4.5 set to be updated
---> Package xorg-x11.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package libvorbis.x86_64 1:1.1.0-2.el4.5 set to be updated
---> Package xorg-x11-font-utils.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package kernel.x86_64 0:2.6.9-55.0.12.EL set to be installed
---> Package xorg-x11-Mesa-libGL.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package nfs-utils-lib.x86_64 0:1.0.6-8.z1 set to be updated
---> Package kdebase.x86_64 6:3.3.1-6.el4 set to be updated
---> Package irb.x86_64 0:1.8.1-7.EL4.8.1 set to be updated
---> Package cyrus-sasl.x86_64 0:2.1.19-14 set to be updated
---> Package xorg-x11-deprecated-libs.i386 0:6.8.2-1.EL.31 set to be updated
---> Package pcre.x86_64 0:4.5-4.el4_5.4 set to be updated
---> Package ruby-libs.x86_64 0:1.8.1-7.EL4.8.1 set to be updated
---> Package libpng10.i386 0:1.0.16-3.el4_5.1 set to be updated
---> Package cyrus-sasl-gssapi.i386 0:2.1.19-14 set to be updated
--> Running transaction check
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: cyrus-sasl-sql
--> Processing Dependency: libmysqlclient.so.14 for package: cyrus-sasl-sql
--> Finished Dependency Resolution
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package cyrus-sasl-sql
Error: Missing Dependency: libmysqlclient.so.14 is needed by package cyrus-sasl-sql
Anyone have an idea how to fix this problem?

Thanks in advance.

DhoTjai
 

adamp

Verified User
Joined
Jan 11, 2007
Messages
141
There is also a problem with the mysql package - the only way I can get an automatic yum update to work is with the following command:

yum -y --exclude="postgres*" --exclude="php*" --exclude="mysql*" update

The original CentOs install was a 'install everything' option.
 

Randy

Verified User
Joined
Sep 30, 2005
Messages
118
Location
The Netherlands
nano /etc/yum.conf

Add the line:
Code:
exclude=apache* httpd* mod_* mysql* MySQL* da_* *ftp* exim* sendmail* php* named* clamav* openssl*
Yum will not try to update the packages listed above anymore. The updatescript/custombuild will. So there will be no more conflicts.

Dutch:
mocht het niet lukken, stuur even een PM help ik je remote verder.
 

DhoTjai

Verified User
Joined
Apr 23, 2006
Messages
80
Location
Netherlands
Hello,

After replacing the exclude line, I ran yum update again and get the following:
Setting up Update Process
Setting up repositories
kbs-CentOS-Extras 100% |=========================| 951 B 00:00
update 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-devel.x86_64 0:2.6.9-55.0.12.EL set to be installed
---> Package xorg-x11-xauth.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package seamonkey-nss.i386 0:1.0.9-6.el4.centos set to be updated
---> Package libpng.i386 2:1.2.7-3.el4_5.1 set to be updated
---> Package cyrus-sasl-sql.i386 0:2.1.19-14 set to be updated
---> Package tzdata.noarch 0:2007h-1.el4 set to be updated
---> Package cyrus-sasl-ntlm.i386 0:2.1.19-14 set to be updated
---> Package qt.x86_64 1:3.3.3-13.RHEL4 set to be updated
---> Package qt.i386 1:3.3.3-13.RHEL4 set to be updated
---> Package cyrus-sasl-md5.i386 0:2.1.19-14 set to be updated
---> Package cyrus-sasl-md5.x86_64 0:2.1.19-14 set to be updated
---> Package kernel-smp.x86_64 0:2.6.9-55.0.12.EL set to be installed
---> Package ruby.x86_64 0:1.8.1-7.EL4.8.1 set to be updated
---> Package seamonkey-nss.x86_64 0:1.0.9-6.el4.centos set to be updated
---> Package kdebase.i386 6:3.3.1-6.el4 set to be updated
---> Package seamonkey-nspr.x86_64 0:1.0.9-6.el4.centos set to be updated
---> Package cups-libs.i386 1:1.1.22-0.rc1.9.20.2.el4_5.2 set to be updated
---> Package cups-libs.x86_64 1:1.1.22-0.rc1.9.20.2.el4_5.2 set to be updated
---> Package ruby-libs.i386 0:1.8.1-7.EL4.8.1 set to be updated
---> Package kdelibs.x86_64 6:3.3.1-9.el4 set to be updated
---> Package cyrus-sasl.i386 0:2.1.19-14 set to be updated
---> Package cups.x86_64 1:1.1.22-0.rc1.9.20.2.el4_5.2 set to be updated
---> Package seamonkey-nspr.i386 0:1.0.9-6.el4.centos set to be updated
---> Package xorg-x11-libs.i386 0:6.8.2-1.EL.31 set to be updated
---> Package xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.31 set to be updated
---> Package flac.i386 0:1.1.0-7.el4_5.2 set to be updated
---> Package kdelibs.i386 6:3.3.1-9.el4 set to be updated
---> Package ruby-devel.x86_64 0:1.8.1-7.EL4.8.1 set to be updated
---> Package xorg-x11-xdm.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Downloading header for perl to pack into transaction set.
perl-5.8.5-36.el4_5.2.x86 100% |=========================| 413 kB 00:00
---> Package perl.x86_64 3:5.8.5-36.el4_5.2 set to be updated
---> Package kernel-smp-devel.x86_64 0:2.6.9-55.0.12.EL set to be updated
---> Package cyrus-sasl-plain.x86_64 0:2.1.19-14 set to be updated
---> Package xorg-x11-libs.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package cyrus-sasl-devel.x86_64 0:2.1.19-14 set to be updated
---> Package xorg-x11-xfs.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package xorg-x11-Mesa-libGLU.i386 0:6.8.2-1.EL.31 set to be updated
---> Package cyrus-sasl-plain.i386 0:2.1.19-14 set to be updated
---> Package libvorbis-devel.x86_64 1:1.1.0-2.el4.5 set to be updated
---> Package pcre.i386 0:4.5-4.el4_5.4 set to be updated
---> Package libvorbis.i386 1:1.1.0-2.el4.5 set to be updated
---> Package xorg-x11.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package libvorbis.x86_64 1:1.1.0-2.el4.5 set to be updated
---> Package xorg-x11-font-utils.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package kernel.x86_64 0:2.6.9-55.0.12.EL set to be installed
---> Package ruby-libs.x86_64 0:1.8.1-7.EL4.8.1 set to be updated
---> Package nfs-utils-lib.x86_64 0:1.0.6-8.z1 set to be updated
---> Package kdebase.x86_64 6:3.3.1-6.el4 set to be updated
---> Package irb.x86_64 0:1.8.1-7.EL4.8.1 set to be updated
---> Package cyrus-sasl.x86_64 0:2.1.19-14 set to be updated
---> Package xorg-x11-deprecated-libs.i386 0:6.8.2-1.EL.31 set to be updated
---> Package xorg-x11-Mesa-libGL.x86_64 0:6.8.2-1.EL.31 set to be updated
---> Package pcre.x86_64 0:4.5-4.el4_5.4 set to be updated
---> Downloading header for perl-MailTools to pack into transaction set.
perl-MailTools-1.77-1.el4 100% |=========================| 11 kB 00:00
---> Package perl-MailTools.noarch 0:1.77-1.el4.centos set to be updated
---> Package libpng10.i386 0:1.0.16-3.el4_5.1 set to be updated
---> Package cyrus-sasl-gssapi.i386 0:2.1.19-14 set to be updated
--> Running transaction check
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: cyrus-sasl-sql
--> Processing Dependency: libmysqlclient.so.14 for package: cyrus-sasl-sql
--> Finished Dependency Resolution
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package cyrus-sasl-sql
Error: Missing Dependency: libmysqlclient.so.14 is needed by package cyrus-sasl-sql
 
Top