Yum update error

Status
Not open for further replies.

chan

New member
Joined
May 14, 2016
Messages
1
I got errors after update. How can I fix it?

Transaction Check Error:
file /usr/bin/update-gdk-pixbuf-loaders from install of gtk2-2.10.4-30.el5.i386 conflicts with file from package gtk2-2.10.4-21.el5_7.7.x86_64
file /usr/bin/update-gtk-immodules from install of gtk2-2.10.4-30.el5.i386 conflicts with file from package gtk2-2.10.4-21.el5_7.7.x86_64
file /usr/share/ghostscript/8.70/Resource/Init/pdf_base.ps from install of ghostscript-8.70-15.el5_9.3.i386 conflicts with file from package ghostscript-8.70-14.el5.x86_64
file /usr/share/devhelp/books/dbus/dbus-specification.html from install of dbus-devel-1.1.2-21.el5.i386 conflicts with file from package dbus-devel-1.1.2-21.el5.x86_64
file /usr/share/locale/ja/LC_MESSAGES/Linux-PAM.mo from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/locale/ko/LC_MESSAGES/Linux-PAM.mo from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/locale/zh_CN/LC_MESSAGES/Linux-PAM.mo from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/locale/zh_TW/LC_MESSAGES/Linux-PAM.mo from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man5/access.conf.5.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man5/limits.conf.5.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man5/namespace.conf.5.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_access.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_cracklib.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_exec.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_faildelay.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_lastlog.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_limits.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_namespace.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_pwhistory.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_selinux.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_succeed_if.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_time.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_tty_audit.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man1/fastjar.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/gcj-dbtool.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/gij.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/grepjar.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/grmic.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/grmiregistry.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/jv-convert.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64

Error Summary
-------------
 

root403

Verified User
Joined
Jul 31, 2016
Messages
6
i386 conflict with x86_64

I got errors after update. How can I fix it?

Transaction Check Error:
file /usr/bin/update-gdk-pixbuf-loaders from install of gtk2-2.10.4-30.el5.i386 conflicts with file from package gtk2-2.10.4-21.el5_7.7.x86_64
file /usr/bin/update-gtk-immodules from install of gtk2-2.10.4-30.el5.i386 conflicts with file from package gtk2-2.10.4-21.el5_7.7.x86_64
file /usr/share/ghostscript/8.70/Resource/Init/pdf_base.ps from install of ghostscript-8.70-15.el5_9.3.i386 conflicts with file from package ghostscript-8.70-14.el5.x86_64
file /usr/share/devhelp/books/dbus/dbus-specification.html from install of dbus-devel-1.1.2-21.el5.i386 conflicts with file from package dbus-devel-1.1.2-21.el5.x86_64
file /usr/share/locale/ja/LC_MESSAGES/Linux-PAM.mo from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/locale/ko/LC_MESSAGES/Linux-PAM.mo from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/locale/zh_CN/LC_MESSAGES/Linux-PAM.mo from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/locale/zh_TW/LC_MESSAGES/Linux-PAM.mo from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man5/access.conf.5.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man5/limits.conf.5.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man5/namespace.conf.5.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_access.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_cracklib.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_exec.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_faildelay.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_lastlog.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_limits.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_namespace.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_pwhistory.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_selinux.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_succeed_if.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_time.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man8/pam_tty_audit.8.gz from install of pam-0.99.6.2-14.el5_11.i386 conflicts with file from package pam-0.99.6.2-6.el5_5.2.x86_64
file /usr/share/man/man1/fastjar.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/gcj-dbtool.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/gij.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/grepjar.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/grmic.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/grmiregistry.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64
file /usr/share/man/man1/jv-convert.1.gz from install of libgcj-4.1.2-55.el5.i386 conflicts with file from package libgcj-4.1.2-52.el5_8.1.x86_64

Error Summary
-------------
You are trying update 32bit package on 64bit system. Please check your repos of yum!
 

Tommyhara

Verified User
Joined
Jul 25, 2014
Messages
162
I got errors after update. How can I fix it?
What command have you run with?

If you want to update yum, using this

Code:
yum update
I also have upgrade yum for my server and it has no error.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,395
Location
Maastricht
gtk2-2.10.4-30.el5.i386 conflicts with file from package gtk2-2.10.4-21.el5_7.7.x86_64
It looks like you're using the wrong repository or something, because you can't update a 64-bit (x86_64) system with 32bit (i386) files and that is exactly what is happening and why you are getting these errors.
 
Status
Not open for further replies.
Top