Admin level domain and LetsEncrypt

ingvar3000

New member
Joined
Nov 12, 2019
Messages
2
I'm having trouble getting an SSL cert on the root domain of the my server hostname.

I've been getting this error message:
Code:
Account admin with domain rootdomain.net has an empty caroot cert
The file:
/usr/local/directadmin/data/users/admin/domains/rootdomain.net.cacert

belonging to account admin, domain rootdomain.net, is either empty or missing,
but it's set to be used in that domain's config.
This is an incorrect state, so please re-add or unset file, and notify DirectAdmin support if it re-occurs.
I recently renamed the server hostname and ran the Letsencrypt script, so now https://host.rootdomain.net has the cert lock. But https:rootdomain.net does not. rootdomain.net is attached to the "admin" account. I would like to have an actual website at rootdomain.net. What am I missing here?
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,218
Location
Maastricht
What exactly did you do?
I recently renamed the server hostname and ran the Letsencrypt script
Like this with the request_single? And did you do every step, including the directadmin.conf change and restarting directadmin?
https://help.directadmin.com/item.php?id=629

Did you also enable everything to be able to activate a certificate for rootdomain.net and used the create function from user level in admin afterwards?
https://help.directadmin.com/item.php?id=648

Do you use the latest DA version or at least 1592 or newer? As this looks like an issue which was fixed before:
https://www.directadmin.com/features.php?id=2552
 

ingvar3000

New member
Joined
Nov 12, 2019
Messages
2
Richard, thanks for the feedback. I think the problem was that the Centos hostname was something completely different. I changed that to match the DirectAdmin settings, ran through the scripts you recommended again, and the empty caroot cert problem resolved.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,218
Location
Maastricht
You're welcome.
Indeed the hostname should be the same as in DA. So it's good you found the cause. Thank you for reporting back.
 
Top