Bug uploading mysql backup?

NoBaloney2

NoBaloney Internet Svcs.
Joined
Jun 17, 2007
Messages
498
Location
California
DirectAdmin 1.45.4
When logged in as reseller, as admin, or as end user, trying to upload a mysql backup .gz file:

https://da603.namelessnet.net:2222/CMD_DB

I get this error message from my Chrome browser:

Code:
This webpage is not available
The connection to da603.namelessnet.net was interrupted.
Anyone else seeing this problem?

Jeff
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Hello,

Timeouts on Administrator Settings page? Or Max Request/Upload Size (bytes)? How big is your MySQL gzipped backup?
 

nobaloney

NoBaloney Internet Svcs - In Memoriam †
Joined
Jun 16, 2003
Messages
26,119
Location
California
Good points, Alex.

The backup was huge. 800 MB, but I got the message insantly so I didn't think that was the issue. If you think it's the issue even if the page comes up immediately, then I'll accept that as the reason.

Otherwise, one more detail: skin is Enhanced

Thanks!

Jeff
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Jeff,


Only John can say it for sure. My tests show that when you try to upload a MySQL dump bigger than it's specified in "Max Request/Upload Size (bytes)" you get immediate connection reset.


Code:
net::ERR_CONNECTION_RESET
Thus we might need to ask John to make directadmin to drop a text error with details instead of closing connection.

Regards,
Alex.
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,021
Looking at the code, DA does generate an error page..
The issue is probably that browser isn't going to be looking for a response yet, since it's still uploading.
The first thing it notices is the closed socket, (DA is already done sending a response before the upload is done..)
so the browser throws the closed socket, rather than the error message that DA sent out...
That's my guess.

There might be a better way of doing that... perhaps using an ajax uploader would be a better option.

I also just noticed that the MAX_FILE_SIZE form option wasn't set on the MytSQL page, so I've added that in.
I'm not sure if browsers respect it, but if they do, that would prevent the upload from starting.

John
 
Top