Can't install PHP 7.4

Gijsdtdev

Verified User
Joined
Aug 27, 2019
Messages
6
I want to install the new PHP 7.4 through the CustomBuild 2.0 plugin on our DirectAdmin server but when I try to build it, it stops the build at the following lines:
Code:
[ 85%] Linking C shared library libzip.so
[ 85%] Built target zip
make: *** [all] Error 2
I saw that PHP 7.4 changed its dependencies so I tried to build libzip seperately but it gives the exact same error.
So what extra steps do I need to take to install PHP 7.4 or is there something wrong with our server?
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,347
Location
LT, EU
Is that the latest version? I'd suggest rev. 2301 or later.
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,347
Location
LT, EU
Hm.. Maybe an older mirror. Anyway, if you do this from CLI, this would let you compile PHP then:
Code:
ln -s /usr/bin/cmake3 /usr/bin/cmake
Or just wait until your download mirror has rev. 2301 :)
 

Gijsdtdev

Verified User
Joined
Aug 27, 2019
Messages
6
I pressed 'Update CustomBuild Script & Versions (only)' for once instead of 'Update CustomBuild' and that did the trick. It works now.

Thanks for the help once again!
 
Top