CentOS 8 Stream and repos renaming

rotame

Verified User
Joined
Jul 4, 2019
Messages
54
Today I tried to update to 8.3 and received the following message
A package conflict is preventing me from upgrading to 8.3.

[root@srv ~]# dnf update
Last metadata expiration check: 2:45:49 ago on Sun 13 Dec 2020 05:22:07 PM CET.
Error:
Problem: cannot install both oniguruma-6.8.2-2.el8.x86_64 and oniguruma-6.8.2-1.el8.x86_64
- package oniguruma-devel-6.8.2-1.el8.x86_64 requires oniguruma = 6.8.2-1.el8, but none of the providers can be installed
- cannot install the best update candidate for package oniguruma-6.8.2-1.el8.x86_64
- problem with installed package oniguruma-devel-6.8.2-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I passed via dnf with the --nobest option

Just for your reference with Centos stream has start to change the names of the .repo files and rename them to lower case names

Any who use CENTOS 8 will face many problems soon
 

Erulezz

Verified User
Joined
Sep 14, 2015
Messages
514
Location
Arnhem, NL
PowerTools has been renamed to just powertools.

Enable it again with: dnf config-manager --set-enabled powertools

Verify with: dnf repolist all
 

Marius B

Verified User
Joined
May 1, 2020
Messages
57
Today I tried to update to 8.3 and received the following message
A package conflict is preventing me from upgrading to 8.3.

[root@srv ~]# dnf update
Last metadata expiration check: 2:45:49 ago on Sun 13 Dec 2020 05:22:07 PM CET.
Error:
Problem: cannot install both oniguruma-6.8.2-2.el8.x86_64 and oniguruma-6.8.2-1.el8.x86_64
- package oniguruma-devel-6.8.2-1.el8.x86_64 requires oniguruma = 6.8.2-1.el8, but none of the providers can be installed
- cannot install the best update candidate for package oniguruma-6.8.2-1.el8.x86_64
- problem with installed package oniguruma-devel-6.8.2-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I passed via dnf with the --nobest option

Just for your reference with Centos stream has start to change the names of the .repo files and rename them to lower case names

Any who use CENTOS 8 will face many problems soon
dnf update --allowerasing
 

maxi32

Verified User
Joined
Jul 25, 2016
Messages
210
Location
Malaysia
Today I tried to update to 8.3 and received the following message
A package conflict is preventing me from upgrading to 8.3.

[root@srv ~]# dnf update
Last metadata expiration check: 2:45:49 ago on Sun 13 Dec 2020 05:22:07 PM CET.
Error:
Problem: cannot install both oniguruma-6.8.2-2.el8.x86_64 and oniguruma-6.8.2-1.el8.x86_64
- package oniguruma-devel-6.8.2-1.el8.x86_64 requires oniguruma = 6.8.2-1.el8, but none of the providers can be installed
- cannot install the best update candidate for package oniguruma-6.8.2-1.el8.x86_64
- problem with installed package oniguruma-devel-6.8.2-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I passed via dnf with the --nobest option

Just for your reference with Centos stream has start to change the names of the .repo files and rename them to lower case names

Any who use CENTOS 8 will face many problems soon

I have noticed this too. Actually, now CentOS already in stream repo and it's not recommended to be used in Production. It's time to move, I think Debian would be a good choice for DirectAdmin
 

ivlad

New member
Joined
Dec 10, 2020
Messages
4
Well, this totally sucks. Time to convert my project server over. :(
 

ccto

Verified User
Joined
Feb 24, 2005
Messages
167
Location
Hong Kong
I encountered the same in my CentOS 8.2 dev server one.

It seems DirectAdmin custombuild (build v2648) use PowerTools repository to install oniguruma-devel
yum -y install oniguruma-devel --enablerepo=PowerTools

where the CentOS 8 ones want to remove it

[root@xxxx custombuild]# yum update oniguruma oniguruma-devel --allowerasing
Last metadata expiration check: 0:11:21 ago on Sun 10 Jan 2021 06:53:46 PM HKT.
Dependencies resolved.
=============================================================================================================================================================
Package Architecture Version Repository Size
=============================================================================================================================================================
Upgrading:
oniguruma x86_64 6.8.2-2.el8 AppStream 187 k
Removing dependent packages:
oniguruma-devel x86_64 6.8.2-1.el8 @PowerTools 170 k

Transaction Summary
=============================================================================================================================================================
Upgrade 1 Package
Remove 1 Package

Total download size: 187 k
Is this ok [y/N]:

Not sure the next steps.
 

ikkeben

Verified User
Joined
May 22, 2014
Messages
1,012
Location
Netherlands Germany
I encountered the same in my CentOS 8.2 dev server one.

It seems DirectAdmin custombuild (build v2648) use PowerTools repository to install oniguruma-devel


where the CentOS 8 ones want to remove it



Not sure the next steps.
Please read this topic also above you can find solution i think.

PowerTools has been renamed to just powertools.

Enable it again with: dnf config-manager --set-enabled powertools

Verify with: dnf repolist all
Maybe DA Custombuild need to update that to?
 

ccto

Verified User
Joined
Feb 24, 2005
Messages
167
Location
Hong Kong
I managed to update CL 8.2 to CL 8.3 in my testing environment by
- yum erase oniguruma-devel
- yum install oniguruma-devel --enablerepo=PowerTools ( <-- same command inside custombuild build script)
it will install oniguruma-devel via PowerTools, and oniguruma via AppStream

Then, "yum update" it will update the remaining, reboot, it looks OK.
 
Top