DirectAdmin v1.642 has been released

k1l0b1t

Verified User
Joined
May 10, 2020
Messages
496
Location
Belgium
@fln Bug with the DNS administration, as an admin it does not show _all_ users like before. It skips all users that are below a reseller.
 

fln

Administrator
Staff member
Joined
Aug 30, 2021
Messages
297
Directadmin doesnot works i m unable to login while checking debug logs its showing in correct password but on page it show login successfully but again page refreshs to the same
Please fill a support ticket. This will allow us to investigate the issue further.
 

fln

Administrator
Staff member
Joined
Aug 30, 2021
Messages
297
An update have been released (build 27491c34f8cd42d011bffa8d59c8f32f99bb1a5a), with the following Evolution skin changes:
  • Darker color for links inside tables, thanks @beansbaxter
  • No errors when going to new FTP account, DB, responder pages from the search bar, thanks @dafang
  • Admin sees all domains in DNS administration page, thanks @k1l0b1t
 

k1l0b1t

Verified User
Joined
May 10, 2020
Messages
496
Location
Belgium
@fln small visual bug in darkmode: same on desktop.
 

Attachments

  • Screenshot_20220807-211932_Firefox~2.jpg
    Screenshot_20220807-211932_Firefox~2.jpg
    46.5 KB · Views: 13

DanielP

Verified User
Joined
Jun 28, 2019
Messages
156
this 1.642 skin update is a little night mare now i have 2 VPS with this

I even tried with refreshed skin so it is not icon grid related

When i switch back to stable 1.63.9 everything works
 

Attachments

  • current.jpg
    current.jpg
    114.7 KB · Views: 10

Amplificator

Verified User
Joined
Jul 2, 2019
Messages
54
this 1.642 skin update is a little night mare now i have 2 VPS with this

I even tried with refreshed skin so it is not icon grid related

When i switch back to stable 1.63.9 everything works
I have the same error. Indeed, this update seems like an oopsie.. too much is broken.
 

fln

Administrator
Staff member
Joined
Aug 30, 2021
Messages
297
@DanielP, thanks for your post. This is a known issue that can be triggered when upgrading from an older DA version directly to current. It is caused by old Evolution customizations migration failure. We are working on an update to automatically resolve this.

This can be fixed manually by just removing old customizations file:

Code:
rm /usr/local/directadmin/data/users/admin/skin_customizations/evolution/files/config.json

But I would recommend waiting for an update.
 

DanielP

Verified User
Joined
Jun 28, 2019
Messages
156
@DanielP, thanks for your post. This is a known issue that can be triggered when upgrading from an older DA version directly to current. It is caused by old Evolution customizations migration failure. We are working on an update to automatically resolve this.

This can be fixed manually by just removing old customizations file:

Code:
rm /usr/local/directadmin/data/users/admin/skin_customizations/evolution/files/config.json

But I would recommend waiting for an update.

rm /usr/local/directadmin/data/users/admin/skin_customizations/evolution/files/config.json does not worked for me, but

I removed evolution folder in /usr/local/directadmin/data/users/admin/skin_customizations/ and it works

Thx
 

Peter Laws

Verified User
Joined
Sep 13, 2008
Messages
2,260
Location
London UK
There's no way to update DA with my situation..... The GUI tells me there's an update - a (1) next to the Updates menu option - nothing when I go there, same with CB via ssh.......

v1.641
 

buHost

Verified User
Joined
Dec 28, 2019
Messages
18
It seems that some items are missing in "DNS Administration".

1.641 (build d1f1ed9f3fda0faa809e53b522e130d5083ccd39)
1659911807964.png


1.642 (build 27491c34f8cd42d011bffa8d59c8f32f99bb1a5a)
1659911952233.png
 

paulonichio

Verified User
Joined
Jul 8, 2019
Messages
28
Has there been any change in the DirectAdmin translation?
I translated the pt_BR.po file and threw it in the folder

/usr/local/directadmin/data/skins/evolution/lang

Then I generated a Json and threw it in the folder:

/usr/local/directadmin/data/skins/evolution/assets/translations/custom

And the language change does not occur, remaining the incomplete translation of the DirectAdmin translation system.

img.png

Another problem is that we put the CSS for the subtheme, but in Firefox, the logo doesn't appear. Chrome, Safari and other browsers display normally.

img2.png

Another problem is that by default we use Portuguese (BR) as the default language on the server. Since the last version, when logging into the system in a browser without cache, the English language is loaded by default, and every time we need to go and change it to pt_BR.

Thanks for helping me with these issues. ;)
 

drukpa

Verified User
Joined
Aug 30, 2019
Messages
18
One of our servers got updated to 1.642 and the evolution skin stopped working on al users giving the following error:

oops!
Privileges needed to load the skin have not been granted for this account or unexpected issue has happened. Please contact your administrator.


I have downgraded the directadmin version and it's working correctly again. Please have a look into this bug.

I am getting the same error as well but only on users created by resellers. For users created by the admin, there's no problem.
 

fln

Administrator
Staff member
Joined
Aug 30, 2021
Messages
297
hi everyone, one more update is pushed out (build id 3cd1f505f05d781bbb4cb5b91e8992dd7d1e5e3d). Key changes:
  • Fixed Oops! errors when migrating from old customizations. Customizations will be converted to new format and preserved. Reported by @DanielP and @Amplificator and probably by @drukpa
  • Fixed table headers as reported by @Erulezz
@paulonichio there is no need to convert translations to JSON and move to custom directory, just keep your translations in .po format in /usr/local/directadmin/data/skins/evolution/lang and set language_list in directadmin.conf:

Code:
$ da config-set language_list en:pt_BR --restart
language_list=en:pt_BR

Setting language_list to a non empty turns Evolution into backwards compatible mode and it uses .po files from /usr/local/directadmin/data/skins/evolution/lang. When this flag is empty Evolution uses languages that comes built-in. Dealing with JSON files was a temporary workaround until we implemented backwards-compatibility mode.
 

Amplificator

Verified User
Joined
Jul 2, 2019
Messages
54
hi everyone, one more update is pushed out (build id 3cd1f505f05d781bbb4cb5b91e8992dd7d1e5e3d). Key changes:
  • Fixed Oops! errors when migrating from old customizations. Customizations will be converted to new format and preserved. Reported by @DanielP and @Amplificator and probably by @drukpa
  • Fixed table headers as reported by @Erulezz

I just updated to that commit and the issue is still there with the Oops error: https://share.cleanshot.com/qlkDScAVUH3Ykk8kwhtA
Both administrators and regular users.
 

dafang

Verified User
Joined
Dec 15, 2019
Messages
35
hi everyone, one more update is pushed out (build id 3cd1f505f05d781bbb4cb5b91e8992dd7d1e5e3d). Key changes:
  • Fixed Oops! errors when migrating from old customizations. Customizations will be converted to new format and preserved. Reported by @DanielP and @Amplificator and probably by @drukpa
  • Fixed table headers as reported by @Erulezz
@paulonichio there is no need to convert translations to JSON and move to custom directory, just keep your translations in .po format in /usr/local/directadmin/data/skins/evolution/lang and set language_list in directadmin.conf:

Code:
$ da config-set language_list en:pt_BR --restart
language_list=en:pt_BR

Setting language_list to a non empty turns Evolution into backwards compatible mode and it uses .po files from /usr/local/directadmin/data/skins/evolution/lang. When this flag is empty Evolution uses languages that comes built-in. Dealing with JSON files was a temporary workaround until we implemented backwards-compatibility mode.

@fln Are these values valid to set the language choices to British (main), American, and Canadian English? It doesn't seem to work as I'm getting an error: "Cannot find the .po file for en_GB (or en_CA), or it's empty".
Code:
[[email protected] ~]# /usr/local/directadmin/directadmin c | grep -i language
language=en_GB
language_list=en_GB:en:en_CA
 
Last edited:

fln

Administrator
Staff member
Joined
Aug 30, 2021
Messages
297
@Amplificator , could you please do:

Code:
tar cvzf /tmp/customizations.tar.gz -C /usr/local/directadmin/data/users/admin/skin_customizations/evolution .

And send me the customizations.tar.gz on a private message to investigate this issue further. Maybe your issue is not the same we have fixed.
 

Amplificator

Verified User
Joined
Jul 2, 2019
Messages
54
@Amplificator , could you please do:

Code:
tar cvzf /tmp/customizations.tar.gz -C /usr/local/directadmin/data/users/admin/skin_customizations/evolution .

And send me the customizations.tar.gz on a private message to investigate this issue further. Maybe your issue is not the same we have fixed.
Sent.
 
Top