DirectSlave/GO 3 - public beta

strefapc

New member
Joined
Apr 27, 2021
Messages
4
I installed directslave on centos 7. After adding the domain in DA it doesn't export dns zone to server directslave. What could be the reason?
 

strefapc

New member
Joined
Apr 27, 2021
Messages
4
I set up a multiserver in DA. Anything else needs to be set?View attachment 4316
named.run

all zones loaded
running
zone test.net/IN: refresh: unexpected rcode (REFUSED) from master xxx.xxx.xxx.xxx#53 (source 0.0.0.0#0)
zone test.net/IN: Transfer started.
transfer of 'test.net/IN' from xxx.xxx.xxx.xxx#53: connected using xxx.xxx.xxx.xxx#60132
transfer of 'test.net/IN' from xxx.xxx.xxx.xxx#53: failed while receiving responses: NOTAUTH
transfer of 'test.net/IN' from xxx.xxx.xxx.xxx#53: Transfer status: NOTAUTH
transfer of 'test.net/IN' from xxx.xxx.xxx.xxx#53: Transfer completed: 0 messages, 0 records, 0 bytes, 0.027 sec$
managed-keys-zone: Key 20326 for zone . acceptance timer complete: key now trusted
 

roman_m

Verified User
Joined
May 5, 2005
Messages
193
Location
Ukraine, Kiev
named.run

all zones loaded
running
zone test.net/IN: refresh: unexpected rcode (REFUSED) from master xxx.xxx.xxx.xxx#53 (source 0.0.0.0#0)
zone test.net/IN: Transfer started.
transfer of 'test.net/IN' from xxx.xxx.xxx.xxx#53: connected using xxx.xxx.xxx.xxx#60132
transfer of 'test.net/IN' from xxx.xxx.xxx.xxx#53: failed while receiving responses: NOTAUTH
transfer of 'test.net/IN' from xxx.xxx.xxx.xxx#53: Transfer status: NOTAUTH
transfer of 'test.net/IN' from xxx.xxx.xxx.xxx#53: Transfer completed: 0 messages, 0 records, 0 bytes, 0.027 sec$
managed-keys-zone: Key 20326 for zone . acceptance timer complete: key now trusted
You should setup zone transfer on secondary server. Please, consult your DNS server software documentation on how to do this.
 

frog9394

Verified User
Joined
Jun 27, 2008
Messages
25
Thanks!

Pidfile issue is fixed, please update to 3.4.2

https://directslave.com/download
Dear Roman,

Thanks a lot! I just upgrade from 3.4.1 to 3.4.2. The procedure as below.
  1. systemctl stop directslave
  2. copy directslave-3.4.2/etc/systemd/directslave.service to /etc/systemd/system/directslave.sevice
  3. copy directslave-3.4.2 /bin/directslave-linux-amd64 /usr/local/directslave/bin/directslave (I'm using CentOS7)
  4. copy directslave-3.4.2 /www/templates/* to /usr/local/directslave/www/templates
Afterthat, I tried to systemctl start directslave. It cannot start
[[email protected] etc]# systemctl status directslave
● directslave.service - DirectSlave for DirectAdmin
Loaded: loaded (/etc/systemd/system/directslave.service; enabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Sun 2021-05-02 02:27:30 HKT; 1s ago
Process: 8717 ExecStart=/usr/local/directslave/bin/directslave --run (code=exited, status=250)
Main PID: 8717 (code=exited, status=250)

May 02 02:27:30 ds systemd[1]: directslave.service: main process exited, code=exited, status=250/n/a
May 02 02:27:30 ds systemd[1]: Unit directslave.service entered failed state.
May 02 02:27:30 ds systemd[1]: directslave.service failed.
May 02 02:27:30 ds systemd[1]: directslave.service holdoff time over, scheduling restart.
May 02 02:27:30 ds systemd[1]: Stopped DirectSlave for DirectAdmin.
May 02 02:27:30 ds systemd[1]: start request repeated too quickly for directslave.service
May 02 02:27:30 ds systemd[1]: Failed to start DirectSlave for DirectAdmin.
May 02 02:27:30 ds systemd[1]: Unit directslave.service entered failed state.
May 02 02:27:30 ds systemd[1]: directslave.service failed.

And then I try to run by command.
[[email protected] /]# /usr/local/directslave/bin/directslave --run

DEBUG: Running as root (0), dropping privileges to 25:25

*** Starting DirectSlave GO/3.4.2 Advanced server ***
*** (c) Roman Mazur <[email protected]> 2012-2020 ***

Going background.
[[email protected] /]# ps aux |grep directslave
root 8850 0.0 0.1 112916 1128 pts/0 S+ 02:36 0:00 grep --color=auto directslave

It cannot start. Can you help? Thanks!

In the meantime. I run directslave on foreground mode in a screen. It can run in foreground mode without error.
 

roman_m

Verified User
Joined
May 5, 2005
Messages
193
Location
Ukraine, Kiev
Dear Roman,

Thanks a lot! I just upgrade from 3.4.1 to 3.4.2. The procedure as below.
  1. systemctl stop directslave
  2. copy directslave-3.4.2/etc/systemd/directslave.service to /etc/systemd/system/directslave.sevice
  3. copy directslave-3.4.2 /bin/directslave-linux-amd64 /usr/local/directslave/bin/directslave (I'm using CentOS7)
  4. copy directslave-3.4.2 /www/templates/* to /usr/local/directslave/www/templates
Afterthat, I tried to systemctl start directslave. It cannot start
[[email protected] etc]# systemctl status directslave
● directslave.service - DirectSlave for DirectAdmin
Loaded: loaded (/etc/systemd/system/directslave.service; enabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Sun 2021-05-02 02:27:30 HKT; 1s ago
Process: 8717 ExecStart=/usr/local/directslave/bin/directslave --run (code=exited, status=250)
Main PID: 8717 (code=exited, status=250)

May 02 02:27:30 ds systemd[1]: directslave.service: main process exited, code=exited, status=250/n/a
May 02 02:27:30 ds systemd[1]: Unit directslave.service entered failed state.
May 02 02:27:30 ds systemd[1]: directslave.service failed.
May 02 02:27:30 ds systemd[1]: directslave.service holdoff time over, scheduling restart.
May 02 02:27:30 ds systemd[1]: Stopped DirectSlave for DirectAdmin.
May 02 02:27:30 ds systemd[1]: start request repeated too quickly for directslave.service
May 02 02:27:30 ds systemd[1]: Failed to start DirectSlave for DirectAdmin.
May 02 02:27:30 ds systemd[1]: Unit directslave.service entered failed state.
May 02 02:27:30 ds systemd[1]: directslave.service failed.

And then I try to run by command.
[[email protected] /]# /usr/local/directslave/bin/directslave --run

DEBUG: Running as root (0), dropping privileges to 25:25

*** Starting DirectSlave GO/3.4.2 Advanced server ***
*** (c) Roman Mazur <[email protected]> 2012-2020 ***

Going background.
[[email protected] /]# ps aux |grep directslave
root 8850 0.0 0.1 112916 1128 pts/0 S+ 02:36 0:00 grep --color=auto directslave

It cannot start. Can you help? Thanks!

In the meantime. I run directslave on foreground mode in a screen. It can run in foreground mode without error.

Please check if user in /etc/systemd/system/directslave.sevice is same as in main DS config file.
I has built it on debian, there are some differences in bind's UID between cent and deb.
If it does not helps, I will investigate this later. You can safely downgrade to 3.4.1, 3.4.2 is a non-critical patch.
 

frog9394

Verified User
Joined
Jun 27, 2008
Messages
25
Dear Roman,

Thanks for your help. I find the problem in my system. DS 3.4.2 have no problems.

When I fallback to DS 3.4.1. I found "Server *:2224 start error! open /usr/local/directslave/ssl/privkey.pem: permission denied" in /usr/local/directslave/log/error.log. I fix the problem by changing this file's owner to named. Afterthat, there was not problem running DS 3.4.2. But I don't know why this error doesn't show when starting DS 3.4.2 service.

Anyway. Thanks a lot for your help. Have a nice day.
 

roman_m

Verified User
Joined
May 5, 2005
Messages
193
Location
Ukraine, Kiev
Dear Roman,

Thanks for your help. I find the problem in my system. DS 3.4.2 have no problems.

When I fallback to DS 3.4.1. I found "Server *:2224 start error! open /usr/local/directslave/ssl/privkey.pem: permission denied" in /usr/local/directslave/log/error.log. I fix the problem by changing this file's owner to named. Afterthat, there was not problem running DS 3.4.2. But I don't know why this error doesn't show when starting DS 3.4.2 service.

Anyway. Thanks a lot for your help. Have a nice day.

You welcome! Have a nice day too.
 

lordlex

Verified User
Joined
Aug 17, 2008
Messages
56
Location
Romania
Hi. I have a problem and wonder if it's just me or there's a problem with directslave (3.4.1 and 3.4.2 on CentOS 7)...

So, I have an account I deleted from a DA server connected to two directslave servers, just to add it back clean and empty. The problem is that the domain wasn't deleted from the slaves. Going to the directslave GUI, I tried to delete the domain, it said it's deleted, so I moved on to add the account back to DA... but actually it was not deleted by directslave. Got back to directslave and I clicked edit and without modifying anything clicked save, and directslave added a new line to the named configuration, a duplicate for the same domain, which is weird...

Directslave was at 3.4.1 when I deleted the account and it didn't deleted the zone and duplicated it when edited. I upgraded it to 3.4.2 and the delete button still doesn't work. All owners and permissions are fine, so that's not the problem.

Any idea?
 

roman_m

Verified User
Joined
May 5, 2005
Messages
193
Location
Ukraine, Kiev
Hi. I have a problem and wonder if it's just me or there's a problem with directslave (3.4.1 and 3.4.2 on CentOS 7)...

So, I have an account I deleted from a DA server connected to two directslave servers, just to add it back clean and empty. The problem is that the domain wasn't deleted from the slaves. Going to the directslave GUI, I tried to delete the domain, it said it's deleted, so I moved on to add the account back to DA... but actually it was not deleted by directslave. Got back to directslave and I clicked edit and without modifying anything clicked save, and directslave added a new line to the named configuration, a duplicate for the same domain, which is weird...

Directslave was at 3.4.1 when I deleted the account and it didn't deleted the zone and duplicated it when edited. I upgraded it to 3.4.2 and the delete button still doesn't work. All owners and permissions are fine, so that's not the problem.

Any idea?
Hi!

Please look at the log files - action.log and error.log, what do you see about domains you removed/added?
 

wtptrs

Verified User
Joined
Jul 13, 2015
Messages
301
Hi Roman,

I would like to update from version 3.3 to the current version. Is there an update procedure available online?
 

roman_m

Verified User
Joined
May 5, 2005
Messages
193
Location
Ukraine, Kiev
Hi Roman,

I would like to update from version 3.3 to the current version. Is there an update procedure available online?
Hi!

No, but procedure is easy: download new version archive, extract it then choose appropriate binary from bin folder, then copy it to /usr/local/directslave/bin/directslave. Then copy all web templates from www folder into /usr/local/directslave/www and restart directslave.

Voila.
 

DrTmagic

New member
Joined
Nov 7, 2021
Messages
4
Hi!

No, but procedure is easy: download new version archive, extract it then choose appropriate binary from bin folder, then copy it to /usr/local/directslave/bin/directslave. Then copy all web templates from www folder into /usr/local/directslave/www and restart directslave.

Voila.
I appreciate you, bro. this solved my problem.
 
Top