failed to verify: Unrouteable address


Verified User
Nov 9, 2018
I have a strange problem with exim, and mailing across my servers that I can't seem to explain.

my server's FQDNs are,, etc. I have a few servers. On each server I configured the default domain for the admin user to be (censored of course).

The problem is that since a day I cannot send emails from one server to a mailbox on the other, it gets rejected with the notification failed to verify: Unrouteable address. something's wrong there, and I don't think I changed anything.

On the receiving server, B, I get the errors. However, the configuration should be the same everywhere. Running a caching named on each node, not using directadmin's built-in dns functionality.

Error on sending server (A)

2024-04-22 23:32:02 1rz1Gc-00000000V2g-1ck4 ** [email protected] F=<[email protected]> R=lookuphost T=remote_smtp [178.132.x.x] X=TLS1.2:ECDHE-ECDSA-AES128-GCM-SHA256:128 CV=no: SMTP error from remote mail server after RCPT TO:<[email protected]>: 550-Verification failed for <[email protected]>\n550-Unrouteable address\n550 Sender verify failed

Error on receiving server (B)

2024-04-22 23:34:02 [91.229.x.x] sender verify fail for <[email protected]>: Unrouteable address
2024-04-22 23:34:02 [91.229.x.x] X=TLS1.2:ECDHE-ECDSA-AES128-GCM-SHA256:128 CV=no F=<[email protected]> rejected RCPT <[email protected]>: Sender verify failed

If I check on the receiving server B, I can verify that exim won't verify the sender:

# exim -v -bv [email protected]
[email protected] failed to verify: Unrouteable address

[root@server-b]# dig mx +short
[root@server-b]# dig +short

However, on other servers, it runs fine:

angelo@server-a:~$ exim -v -bv [email protected]
[email protected]
    <-- [email protected]
  router = localuser, transport = local_delivery

[root@server-c ~]# exim -v -bv [email protected]
[email protected]
    <-- [email protected]
  router = localuser, transport = local_delivery

I found a temporary workaround by adding server-a's ip to /etc/virtual/whitelist_hosts_ip, and that makes exim accept mails again, but it's a dirty workaround and not a solution.

Any exim guru's that can help me debug this?
Any exim guru's that can help me debug this?
I'm not a guru but.....

On each server I configured the default domain for the admin user to be (censored of course).
Isn't that causing the issue?
Verification failed for <[email protected]>
Since company is on all servers, all the servers see that as local domains, so unroutable. If I'm not mistaken, as said I'm no guru.
Because Exim will not only look in DNS but also in /etc/virtual/domains and domainowners.

So whitelisting would be the solution.

However, I don't know why it's working on other servers fine then, unless there is some difference in configuration somewhere along the line.
Maybe forgot to set the MX page correctly, this server is not used to send mail for this domain?

Out of curiosity, why do you use on all servers?
Richard is right. The duplicated domain across all the servers is the reason. If you need for any reason the domain to be added on all the servers, then you should make sure:

1. email addresses are also duplicated as well as aliases
2. or if you hold mail accounts of the domain on a single server, the other servers have the option "use the local server to handle emails" disabled for the specific domain.

And make sure DNS records point to a correct IP where the mail server handles all incoming emails.