Imagick update issue

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
Have imagick running on 2 servers. After update to 8.02 this is happening on both servers

Code:
PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
How can I fix this?

Seems to be fixed by running:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build imagick
However, this should not happen on a ./build update_versions on multiple servers, correct?
 
Last edited:

Richard G

Verified User
Joined
Jul 6, 2008
Messages
4,541
Location
Maastricht
Seems imagick is gone from options.conf, or is that normal?
Code:
[root@server24: /usr/local/directadmin/custombuild]# ./build set imagick yes
Changed imagick option from yes to yes
So let's check options.conf:
Code:
[root@server24: /usr/local/directadmin/custombuild]# cat options.conf | grep imag
[root@server24: /usr/local/directadmin/custombuild]#
I also looked in there with nano, it's not to be found.

Maybe that caused the previous issue?
 

wavoe

Verified User
Joined
Nov 21, 2007
Messages
67
Location
Belgium
Have imagick running on 2 servers. After update to 8.02 this is happening on both servers

Code:
PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
How can I fix this?

Seems to be fixed by running:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build imagick
However, this should not happen on a ./build update_versions on multiple servers, correct?
Also had this yesterday, that is also what fixed it for me.
In fact "./build imagick" = "./build php_imagick"
And before you probably ran "./build imagemagick"
 

Pinguin29

New member
Joined
Oct 15, 2019
Messages
3
Seems to be fixed by running:
Code:
cd /usr/local/directadmin/custombuild
./build update
./build imagick
However, this should not happen on a ./build update_versions on multiple servers, correct?
that give's me :

Code:
[root@www custombuild]# ./build imagick
./build: line 11520: /usr/local/php73/bin/php-config: No such file or directory
imagick 3.4.4 PHP extension has been installed successfully.
[root@www custombuild]#
my problem:
Code:
[root@www custombuild]# php -v
PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
PHP 7.3.11 (cli) (built: Dec  2 2019 23:25:50) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies
[root@www custombuild]#
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
that give's me :

Code:
[root@www custombuild]# ./build imagick
./build: line 11520: /usr/local/php73/bin/php-config: No such file or directory
imagick 3.4.4 PHP extension has been installed successfully.
[root@www custombuild]#
my problem:
Code:
[root@www custombuild]# php -v
PHP Warning:  Version warning: Imagick was compiled against ImageMagick version 1801 but version 1802 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
PHP 7.3.11 (cli) (built: Dec  2 2019 23:25:50) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.11, Copyright (c) 1998-2018 Zend Technologies
[root@www custombuild]#
Are you running rev. 2446? Please check ./build version
 

smtalk

Administrator
Staff member
Joined
Aug 22, 2006
Messages
8,916
Location
LT, EU
I think you have PHP 7.3 set as some PHP release enabled, but it's not built. Please check:
Code:
ls /usr/local/php73/bin/php*
The following should fix it:
Code:
./build php
 

Pinguin29

New member
Joined
Oct 15, 2019
Messages
3
I think you have PHP 7.3 set as some PHP release enabled, but it's not built. Please check:
Code:
ls /usr/local/php73/bin/php*
The following should fix it:
Code:
./build php
ls gives me cannot access not a directory
the build php fixed it , thanks !
 
Top