No matching DirectoryIndex (index.php,index.html) found

rifkytech

Verified User
Joined
Feb 26, 2020
Messages
6
Location
Medan, Indonesia
Hello i have some problem, sometime, my client got 503 Service Unvailable, & i found this error on /var/log/httpd/domains/domain.com.error.log

"AH01276: Cannot serve directory /home/dimasaf/domains/domain.com/private_html/: No matching DirectoryIndex (index.php,index.html) found, and server-generated directory index forbidden by Options directive"

and when I reboot the server again, the server returns to normal. whats problem here? i really confused, please help me

i use latest directadmin, and use centOs 7
i use apache2 with php-fpm
 

ericosman

Verified User
Joined
Nov 25, 2019
Messages
63
Location
Weert
If i read it right, it looks for the following files "index.php and index.html" in the home/dimasaf/domains/domain.com/private_html folder (this is the HTTPS folder).
Did the owner of this website copy his site over to your hostingservice?

edit: after a google search i found this:
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Hello,

I believe the error 'No matching DirectoryIndex' is not relative. It's probably because of PHP-FPM hits a limit of max allowed processes. Check what you see there

Code:
/usr/local/directadmin/directadmin c | grep -i php_fpm_max_children_default
and in logs /var/log/php-fpm*.log something like server reached pm.max_children setting (30), consider raising it.
 

rifkytech

Verified User
Joined
Feb 26, 2020
Messages
6
Location
Medan, Indonesia
Hello,

I believe the error 'No matching DirectoryIndex' is not relative. It's probably because of PHP-FPM hits a limit of max allowed processes. Check what you see there

Code:
/usr/local/directadmin/directadmin c | grep -i php_fpm_max_children_default
and in logs /var/log/php-fpm*.log something like server reached pm.max_children setting (30), consider raising it.
yess, how to add size max_children? in my server pm.mac_children only 10
 

Attachments

urgido

Verified User
Joined
Oct 28, 2008
Messages
392
Edit your httpd.conf file. Alex give you a clue for the solution. Just increase that value and restart apache.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
You should not edit httpd.conf and it won't help by the way. Run the following as root:

Code:
/usr/local/directadmin/directadmin set php_fpm_max_children_default 30
cd /usr/local/directadmin/custombuild/
./build rewrite_confs
to set it to 30.
 

zEitEr

Super Moderator
Joined
Apr 11, 2005
Messages
14,255
Location
GMT +7.00
Too big value might bring to issues with high RAM usage and disk IO in case your server is under brute-force attacks. So you need to investigate on why PHP scripts are running slow or hanging....
 

urgido

Verified User
Joined
Oct 28, 2008
Messages
392
You should not edit httpd.conf and it won't help by the way. Run the following as root:

Code:
/usr/local/directadmin/directadmin set php_fpm_max_children_default 30
cd /usr/local/directadmin/custombuild/
./build rewrite_confs
to set it to 30.
That's true. My mistake
 
Top