PEAR errors during upgrade php 7.3/7.4

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
Happened on both upgrades:

Code:
[PEAR] Structures_Graph- already installed: 1.1.1
pear/pear dependency package "pear/XML_Util" downloaded version 1.4.4 is not the recommended version 1.4.3, but may be compatible, use --force to install
pear/XML_Util cannot be installed, conflicts with installed packages
[PEAR] XML_Util       - upgraded:  1.4.4
pear/PEAR dependency package "pear/Archive_Tar" installed version 1.4.9 is not the recommended version 1.4.4, but may be compatible, use --force to install
pear/PEAR dependency package "pear/XML_Util" installed version 1.4.4 is not the recommended version 1.4.3, but may be compatible, use --force to install
[PEAR] PEAR           - upgraded:  1.10.11
So pear/XML conflicts with something and others are not recommended?

Is this a bug, can this safely be ignored, must it be fixed?
 

wattie

Verified User
Joined
May 31, 2008
Messages
1,093
Location
Bulgaria
I did upgrade them ignoring the warning. I did not feel any issues so far. Did that months ago. But not these versions - older.
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
What did you do months ago @wattie ? These php upgrades creating this error were only available since yesterday. So I'm confused.
Or do you mean you had the same error on a previous php update months ago?
 

wattie

Verified User
Joined
May 31, 2008
Messages
1,093
Location
Bulgaria
It's not an error. It's just saying that there are newer versions of some modules but the recommended versions are older than them.

I forced them, eg:

Code:
./pear upgrade --force PEAR
./pear upgrade --force XML_Util
...
I didn't notice any issues so far. Just did upgrade to the newest versions (got the same notice like from your post) but I am still waiting for eventual feedback (I don't see problems but who knows - it's too soon for verdict) :)
 

Richard G

Verified User
Joined
Jul 6, 2008
Messages
5,004
Location
Maastricht
Hmmz... I forced it last time, but don't want to force it every time and it's happening again:
Code:
pear/pear dependency package "pear/XML_Util" downloaded version 1.4.5 is not the recommended version 1.4.3, but may be compatible, use --force to install
pear/XML_Util cannot be installed, conflicts with installed packages
[PEAR] XML_Util       - upgraded:  1.4.5
pear/PEAR dependency package "pear/Archive_Tar" installed version 1.4.9 is not the recommended version 1.4.4, but may be compatible, use --force to install
Isn't there a way to definitely get rid of this pear notices?
 
Top