Php & Imap @ Debian 5 = No ?

panosru

Verified User
Joined
Oct 8, 2006
Messages
80
Location
Greece
I tried everything but even after successful compile of php with imap extension, imap is not shown on phpinfo and does not supported by any php code that uses Imap extension.

Does anyone have similar problem?
 

daveyw

Verified User
Joined
Jan 5, 2008
Messages
702
Location
/dev/null
Then it seems you didn't had a 'sucessfull' compile for PHP with IMAP.

Can you post the output of 'php -m | grep imap'
 

panosru

Verified User
Joined
Oct 8, 2006
Messages
80
Location
Greece
Well, i compiled PHP with IMAP correctly and without any erros but php does not recognize imap extension for some reason...
server:~# php -m | grep imap
imap
server:~#
 

daveyw

Verified User
Joined
Jan 5, 2008
Messages
702
Location
/dev/null
As you see, you have installed 'imap' successfully.
Also have you restarted HTTPd?

You should see something in your PHPInfo page about IMAP.
 

panosru

Verified User
Joined
Oct 8, 2006
Messages
80
Location
Greece
yes i have restarted httpd and the server too, i never had any problem compiling php with imap but i'm new on Debian 5 i followed all the posts of this forum about compiling php with imap but the strange thing is that i have no problem with compile but phpinfo does not show imap extension.... its like i don't put the --with-imap & --with-imap-ssl on php configuration, but i put them and i can see imap on php compile process but after restart nothing happen... :/
 

panosru

Verified User
Joined
Oct 8, 2006
Messages
80
Location
Greece
on phpinfo() i see that on:

Configure Command './configure' '--with-apxs2' '--with-curl=/usr/local/lib' '--with-gd' '--enable-gd-native-ttf' '--with-ttf' '--with-gettext' '--with-jpeg-dir=/usr/local/lib' '--with-freetype-dir=/usr/local/lib' '--with-kerberos' '--with-openssl' '--with-mcrypt' '--with-mhash' '--with-mysql=/usr/local/mysql' '--with-mysqli=/usr/local/mysql/bin/mysql_config' '--with-pdo-mysql=/usr/local/mysql' '--with-pear' '--with-png-dir=/usr/local/lib' '--with-zlib' '--with-zlib-dir=/usr/local/lib' '--enable-zip' '--with-iconv=/usr/local' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-mbstring'
Does not appear the imap extension even if i added it...
 

panosru

Verified User
Joined
Oct 8, 2006
Messages
80
Location
Greece
but i've added the --with-imap=/path/to/imap \ and --with-imap-ssl=/path/to/imap and did ./build php n and didn't worked.. :/
 

daveyw

Verified User
Joined
Jan 5, 2008
Messages
702
Location
/dev/null
but i've added the --with-imap=/path/to/imap \ and --with-imap-ssl=/path/to/imap and did ./build php n and didn't worked.. :/
You had something like this

Code:
--with-imap=/path/to/imap \   --with-imap=/path/to/imap \
instead of
Code:
--with-imap=/path/to/imap \
--with-imap-ssl=/path/to/imap \
 

panosru

Verified User
Joined
Oct 8, 2006
Messages
80
Location
Greece
hmm... i guess the build in sftp editor caused this problem.... next time i will edit it with vi :D thanks again :D
 
Top