PHP works according to Master Value only

idon

Verified User
Joined
Oct 10, 2017
Messages
14
Hello,
I have lsphp (because the openlitespeed) installed on the server.
I want to enable exec function for specific user.

The function exec disabled by the php.ini file, so I override it locally in Virtualhost templates.

The result look good in phpinfo(); (exec function not appear on Local Value column).

But it's not help and the function not really work, I tried to remove exec from Master Value by editing the global php.ini and then the function work well.

so I guess that php take the settings from Master Value (global php.ini). How can I fix it? to make my overide in specific user work well?

thank you
 
Last edited:

jayw1

Verified User
Joined
Nov 20, 2019
Messages
134
Location
USA
Edit /usr/local/phpXX/lib/php.ini replacing XX with whatever PHP version you use.
Find the disable_functions and remove exec.
Restart Litespeed.
 

idon

Verified User
Joined
Oct 10, 2017
Messages
14
Edit /usr/local/phpXX/lib/php.ini replacing XX with whatever PHP version you use.
Find the disable_functions and remove exec.
Restart Litespeed.
Hey, thanks about your reply. But I want to allow this function only for admin user. Your method allow it for all users...
 
Top