Custom Apache Build System

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,798
Location
A Coruña, Spain
configure: error: APR could not be located. Please use the --with-apr option.
configure failed for srclib/apr-util

*** There was an error while trying to configure Apache 2. Check the configure.apache_2 file



now i got this error.. what can i do?

thanks
 

Chrysalis

Verified User
Joined
Aug 25, 2004
Messages
1,584
Location
uk
you are using default switches and deleted nothing else other then the customapache dir?
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,798
Location
A Coruña, Spain
i've deleted all for error.. i've take build from url gived me in this forum and made an build update and build update_data.. and now i got that error...
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

For apache 2? You'd have to run:

./build update_data_ap2

If you just type "./build" you'll get all the things you can run.

John
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Not sure. Have you tried following it's recommendations?
Try adding:
--with-apr
to your configure.apache_2 file.

John
 

SeLLeRoNe

Super Moderator
Joined
Oct 9, 2004
Messages
6,798
Location
A Coruña, Spain
i've tried but i've the same error, the configure.apache_2 is downloaded by build script from your website.. what can be wrong?

checking for chosen layout... apr-util
Applying apr-util hints file rules for i386-unknown-freebsd5.5
checking for APR... no
configure: error: APR could not be located. Please use the --with-apr option.
configure failed for srclib/apr-util

*** There was an error while trying to configure Apache 2. Check the configure.apache_2 file



>uname -a
FreeBSD Flame.CrazyNetwork.it 5.5-PRERELEASE FreeBSD 5.5-PRERELEASE #1:
 

Chrysalis

Verified User
Joined
Aug 25, 2004
Messages
1,584
Location
uk
I have no idea what APR even is so hard to help you here, I checked my configure.apache_2 file and it has no --with-apr defined.
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

By "lost" I'm assuming you mean the just are not showing up?

If that's the case, then you'd likely just be missing your Include lines from the /etc/httpd/conf/httpd.conf

Here is a simple script that will re-fill them (it may add duplicate entries, so you'd have to remove any duplicates)
Code:
cd /usr/local/directadmin/data/users
for i in `ls`; do { echo "Include /usr/local/directadmin/data/users/$i/httpd.conf" >> /etc/httpd/conf/httpd.conf; }; done;
John
 

Fantole

Verified User
Joined
Jun 30, 2006
Messages
26
Hello has all :D

Sorry if my English is bad :rolleyes:

I write here while hoping to find a solution with my problem

I tested this with my Shell to update my GD

PHP:
cd /usr/local/directadmin/customapache 
rm -f configure.php 
./build clean 
./build update 
./build php y
But once this of validated
PHP:
./build php y
At the beginning all goes well, but after its blocks .
I have this error
Server unexpectedly closed network connection

Thus I started again my host, but its did not update anything.
Have said to me to test with Nice.

But I am NOOB and I know nothing there.

Can have to help me ?

Thank you, and sorry if I write at the bad place :(
 

DirectAdmin Support

Administrator
Staff member
Joined
Feb 27, 2003
Messages
9,051
Hello,

I wouldn't recommend using the "./build php y" option as it will throw you into an inifinte loop if the compile fails... eg:
"The compile has failed, do you want to try again (y/n)"
selecting yes would throw you around as you would have selected yes all the time.

Instead use either:

./build php d

or

./build php n

I use "n" myself, as it's faster, but the d is good as it's essentially a "y" (yes) so it will compile any modules that are missing, but will skip existing ones and head straight to php (faster).

If you do want to recompile all php modules as well, then use just:

./build php

and manually select 'y' when it asks you. This will prevent any infinite loops ;)

John
 
Top